54-ФЗ: Онлайн-кассы для 1С 7.7 нетиповая

Публикация № 991465

Учет и отчетность - Кассовые операции

Подключение онлайн кассы к не типовой 1С 7.7 через драйвер атола v10.

Долго искал как подключить Атол 30Ф к 7.7 через драйвер версии 10. Все, что находил, было платно либо не понять, как использовать. В итоге решил сделать бесплатный шаблон. 

1. Качаем драйвер Атола с их сайта и устанавливаем.

2. В папке с установленным драйвером находим addin_fptr10_x86.dll и регистрируем его через regsvr32

3. Берем и встраиваем в Вашу программу шаблон.

Драйвер успешно работает на WindowsXP Home SP3.

Перем FR 

Процедура ОтветДрайвера(КомандаККМ)
    Result=FR.errorCode();
    ОшибкаПараметра=FR.errorDescription();
    Сообщить("Ответ "+Result+" Ошибка "+ОшибкаПараметра);
КонецПроцедуры


Процедура ПодключениеККМ()
   FR = СоздатьОбъект("AddIn.Fptr10"); 
                                                                                                   //LIBFPTR_MODEL_ATOL_AUTO
    FR.setSingleSetting(FR.LIBFPTR_SETTING_MODEL, строка(FR.LIBFPTR_MODEL_ATOL_30F));
    FR.setSingleSetting(FR.LIBFPTR_SETTING_PORT, строка(FR.LIBFPTR_PORT_COM));
    FR.setSingleSetting(FR.LIBFPTR_SETTING_COM_FILE, 1); //"COM"
    FR.applySingleSettings();
    
    Если FR.open()<>0 тогда //Соединение с ККТ 
        ОтветДрайвера("Подключение ККМ");
        СтатусВозврата(0);
        возврат;
    КонецЕсли;
    
    
    //Запрос параметров
    FR.setParam(FR.LIBFPTR_PARAM_DATA_TYPE, FR.LIBFPTR_DT_STATUS);
    FR.queryData();
                
    НомерКассира    = FR.getParamInt(FR.LIBFPTR_PARAM_OPERATOR_ID);
    состояниеСмены  = FR.getParamInt(FR.LIBFPTR_PARAM_SHIFT_STATE);
    ДатаВремя       = FR.getParamInt(FR.LIBFPTR_PARAM_DATE_TIME);
    РежимККТ        = FR.getParamInt(FR.LIBFPTR_PARAM_MODE);
    ПодрежимККТ     = FR.getParamInt(FR.LIBFPTR_PARAM_SUBMODE);
    НомерЧека        = FR.getParamInt(FR.LIBFPTR_PARAM_RECEIPT_NUMBER);
    НомерДокумента  = FR.getParamInt(FR.LIBFPTR_PARAM_DOCUMENT_NUMBER);
    
       FR.setParam(1021, СокрЛП(Пользователь));
    FR.operatorLogin();

    FR.openShift(); //Открыть смену

    FR.checkDocumentClosed();                
    
    ОтветДрайвера("Подключение ККМ");

КонецПроцедуры  


Процедура РаботаККМ()
    
        //Открыть чек
        FR.setParam(1021, СокрЛП(Пользователь));
        FR.operatorLogin();
        
        Если ВозвратныйЧек=1 Тогда
            FR.setParam(FR.LIBFPTR_PARAM_RECEIPT_TYPE, FR.LIBFPTR_RT_SELL_RETURN);
        Иначе
            FR.setParam(FR.LIBFPTR_PARAM_RECEIPT_TYPE, FR.LIBFPTR_RT_SELL);
        КонецЕсли;
        FR.openReceipt();         
        
        //Продажа
        FR.setParam(FR.LIBFPTR_PARAM_COMMODITY_NAME, ЛЕв(Имя,20));
        FR.setParam(FR.LIBFPTR_PARAM_PRICE, ЦенаПродажи);
        FR.setParam(FR.LIBFPTR_PARAM_QUANTITY, Колич);
        FR.setParam(FR.LIBFPTR_PARAM_TAX_TYPE, FR.LIBFPTR_TAX_NO );
        Если ПустоеЗначение(Маркировка)=0 Тогда
            FR.setParam(1162, СокрЛП(Маркировка));
        КонецЕсли;
        
        Если FR.registration() <> 0 тогда
            ОтветДрайвера("Продажа");
            Возврат;
        КонецЕсли;   
        
        
        //Закрыть чек
        Если ВозвратныйЧек=0 Тогда
            //Оплата
            FR.setParam(FR.LIBFPTR_PARAM_PAYMENT_TYPE, FR.LIBFPTR_PT_CASH);
            FR.setParam(FR.LIBFPTR_PARAM_PAYMENT_SUM, СуммаВКассу);
            FR.payment();
        КонецЕсли;
        
        FR.closeReceipt(); 
        
        
        //Z-отчет
            FR.setParam(1021, СокрЛП(Пользователь));
            //fptr.setParam(1203, '123456789047');
            FR.operatorLogin();
    
            FR.setParam(FR.LIBFPTR_PARAM_REPORT_TYPE, FR.LIBFPTR_RT_CLOSE_SHIFT);
            FR.report();

            FR.checkDocumentClosed();
            
            
        //X-отчет
            FR.setParam(1021, СокрЛП(Пользователь));
            //fptr.setParam(1203, '123456789047');
            FR.operatorLogin();
            
            
            FR.setParam(FR.LIBFPTR_PARAM_REPORT_TYPE, FR.LIBFPTR_RT_X);
            FR.report();

                
        //открыть ящик
        FR.openDrawer();
        
    
КонецПроцедуры

Все подробности о методах можно прочитать в документации к драйверу, примеры нужно смотреть для "делфи" с поправкой на синтаксис 1С 7.7

Во вложенном файле то же самое, это для тех, кто хочет отблагодарить.
 

Скачать файлы

Наименование Файл Версия Размер
54-ФЗ: Онлайн-кассы для 1С 7.7 нетиповая:
.ert 17,00Kb
29.01.19
14
.ert 17,00Kb 14 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. user940969 01.02.19 01:01 Сейчас в теме
Как же вовремя статья. Как раз накануне искал как 10-й драйвер Атола подключить. Однозначно плюс
2. monkbest 105 01.02.19 09:05 Сейчас в теме
Есть инфа 100%, что 10й драйвер не нужен, точнее нужен не всегда. Я могу кое-что не так сейчас написать, т.к. не автор драйверов, и это все гипотеза.

Сам поддерживаю 1С7.7 ТиС, который давно не обновлябелен. Цель мероприятия по установке 10ого драйвера в том, чтобы данные в ОФД приходили в новом формате, который не реализован в 8ом драйвере.

Драйвер Атол состоит из 2ух частей: драйвер и служба обмена с ОФД. Драйвер шлет команды в ККМ, а служба шлет данные в ОФД.
Драйвер позволяет работаьь в двух режимах: отправлять в XML формате целиком готовый документ в ККМ или последовательно посылать команды (открыть чек, продать товар 1, продать товар 2, установить скидку, закрыть чек, закрыть смену и т.д.)
В каждой версии драйверов своя dll`ка, для работы через объектную модель и объектная модель собственно разная. Т.е. не просто от версии к версии добавляются новые реквизиты и методы, а они в корне меняются. Обратной совместимости нет. Поэтому автор статьи изучил новую систему команд и реализовал её в 1Сном коде.

После обновления прошивки в ККМ (её делали те, кто обслуживают ККМ) на новый формат, служба EoU стала писать нонстопом ошибку. Видимо, из-за нового формата. Делать нечего, решил что надо ставить 10й драйвер и что-то кодить самому.

Я начал читать документацию по новой системе команд, новой компоненты. Но очень быстро, лень победила и я начал думать. И вот что придумал:

1. Я установил обе версии драйверов
2. Служба EoF запущено от 10й версии
3. COM объект юзаю старый от 8й
4. Обработка торгового оборудования осталась прежней

что нельзя:
нельзя выбить на ККМ новые операции т.к. в 8ом драйвере нет нужных свойств и методов. Всяки авансы, оплаты по банку от физ.лиц...
но в моем случае это и не надо
мне надо:
открыл смену
выбил чек наличными Nраз
закрыл смену

все работает, в офд уходит
5. victuan 3550 16.06.19 07:14 Сейчас в теме
(2) Вы не правы, ДТО8 поддерживает все новые теги, не хуже чем ДТО10.
Готовое решение по ссылке http://infostart.ru/public/603118/
23. phsin 183 01.08.19 18:37 Сейчас в теме
(5) О прекращении поддержки драйверов "АТОЛ: Драйвер ККТ с передачей данных в ОФД (54-ФЗ), 8.x" и "АТОЛ: Драйвер ККТ с передачей данных в ОФД (54-ФЗ), 9.x"
http://1c.ru/news/info.jsp?id=25026

О переходе на ДККТ 10 и прекращении развития и поддержки ДККТ 8 и 9
https://www.atol.ru/company/news/o-perekhode-na-dkkt-10-i-prekrashchenii-razvitiya-i-podderzhki-dkkt-8-i-9-/
3. user1167562 16.05.19 20:32 Сейчас в теме
При работе на 8й версии АТОЛ работает и отправляет, но неверно отправляет ставку НДС, они сменили порядок ставок.
Хорошо быстро обнаружили
4. Санта 11.06.19 10:42 Сейчас в теме
Добрый день! Подскажите пожалуйста по связке 7.7 ТИС и АТОЛ 10?
В Вашем варианте какую dll указывать в настройках торгового оборудования?
6. kalleka 47 24.06.19 13:45 Сейчас в теме
Вариант работает с новыми тегами, которые становятся обязательными с 1 июля?
7. Tarlich 86 02.07.19 21:02 Сейчас в теме
Прошу подсказать :
Тис 9.2 передает в ПечатьЧЕк() списокТоваров (ТаблицаЗначенй)
Данный код работает - все ок!!!
но мне надо добавить цикл что бы печатать товары ,
подскажите как ?
сделал :
Объект.openReceipt(); 		    
	СписокТоваров.ВыбратьСтроки();
	Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл 			 
  Объект.setParam(Объект.LIBFPTR_PARAM_COMMODITY_NAME,СокрЛП(СписокТоваров.ТовНаим));
			Объект.setParam(Объект.LIBFPTR_PARAM_PRICE, СписокТоваров.Цена);
			Объект.setParam(Объект.LIBFPTR_PARAM_QUANTITY, СписокТоваров.Количество);
			Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_NO );
	КонецЦикла;

Печатаеться один товар только .....
11. NikNIklas 09.07.19 11:35 Сейчас в теме
(7) в цикл добавить регистрацию строки Объект.registration();
12. Tarlich 86 09.07.19 11:48 Сейчас в теме
(11)
Объект.registration();

Вот весь мой код :

СписокТоваров.ВыбратьСтроки();
		
		Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл 		
			Объект.openReceipt(); 			
			//Продажа
			Объект.setParam(Объект.LIBFPTR_PARAM_COMMODITY_NAME,СокрЛП(СписокТоваров.ТовНаим));
			Объект.setParam(Объект.LIBFPTR_PARAM_PRICE, СписокТоваров.Цена);
			Объект.setParam(Объект.LIBFPTR_PARAM_QUANTITY, СписокТоваров.Количество);
			Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_NO );			
			Если Объект.registration() <> 0 тогда
				ОтветДрайвера("Продажа",Объект);
				рез = 1;
			КонецЕсли;   	
			//Закрыть чек
			Если ПризнВозврата=0 Тогда
				//Оплата
				Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_TYPE, Объект.LIBFPTR_PT_CASH);
				Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_SUM, СуммаЧека);
				Объект.payment();
			КонецЕсли;		
			Объект.closeReceipt();    			
		КонецЦикла;
Показать
13. NikNIklas 09.07.19 11:59 Сейчас в теме
(12)
Объект.openReceipt();
Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
//Продажа
Объект.setParam(Объект.LIBFPTR_PARAM_COMMODITY_NAME,СокрЛП(СписокТоваров.ТовНаим));
Объект.setParam(Объект.LIBFPTR_PARAM_PRICE, СписокТоваров.Цена);
Объект.setParam(Объект.LIBFPTR_PARAM_QUANTITY, СписокТоваров.Количество);
Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_NO );
Если Объект.registration() <> 0 тогда
ОтветДрайвера("Продажа",Объект);
рез = 1;
КонецЕсли;
КонецЦикла; 
//Закрыть чек
Если ПризнВозврата=0 Тогда
//Оплата
Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_TYPE, Объект.LIBFPTR_PT_CASH);
Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_SUM, СуммаЧека);
Объект.payment();
КонецЕсли;
Объект.closeReceipt();
Показать
8. phsin 183 03.07.19 12:42 Сейчас в теме
Установил версию 10.5.0.0 ДТО
запускаю на win 7

ИмяКомпоненты = "addin_fptr10_x86.dll";
Если ЗагрузитьВнешнююКомпоненту(ИмяКомпоненты) <> 0  Тогда
	Попытка
		driver = СоздатьОбъект("AddIn.Fptr10");
	исключение
		Сообщить("Ошибка при создании объекта "+ИмяКомпоненты,"!");
	конецпопытки;
Иначе
	Сообщить("Ошибка загрузки внешней компоненты "+ИмяКомпоненты+"
	|"+ОписаниеОшибки(),"");
КонецЕсли;
Показать


получаю ошибку:

Ошибка при создании объекта из компоненты C:\1C\test\addin_fptr10_x86.dll (отсутствует интерфейс IInitDone)


можете выложить вашу версию драйвера addin_fptr10_x86.dll ?
14. NikNIklas 10.07.19 12:36 Сейчас в теме
(8) (9) получилось подключить?
21. z5515 4 01.08.19 07:17 Сейчас в теме
(8)(9)(14)

Долго маялся с "addin_fptr10_x86.dll (отсутствует интерфейс IInitDone)"

Потом дошло, ее не надо пытаться подключить как ВК, достаточно зарегистрировать через regsvr32,
и обращаться к объекту "FR = СоздатьОбъект("AddIn.Fptr10"); "
22. NikNIklas 01.08.19 10:01 Сейчас в теме
9. resonance 08.07.19 14:27 Сейчас в теме
( 8) Добрый день, подскажите - удалось ли подключить ФР? отсутствует интерфейс IInitDone Именно такую ошибку получаю
10. NikNIklas 09.07.19 11:34 Сейчас в теме
В настройках указывайте старую длл: FprnM1C.dll. В AddIn - Fptr10
15. resonance 11.07.19 12:58 Сейчас в теме
FprnM1C.dll - указывал и AddIn - Fptr10

ошибка все равно одна и та же - "Служба Frontol не запущена."...
16. victuan 3550 16.07.19 14:08 Сейчас в теме
Готовое решение с поддержкой ДТО8 и ДТО10 по ссылке http://expert.chistov.pro/public/603118/
17. NikNIklas 24.07.19 11:14 Сейчас в теме
1с 7.7 торговля, драйвер 10.5.0, касса по усб. С локального компа на скульной базе печатает влёт. Через РДП касса подключается, видна через параметры и проверку связи, но на печать не выдает ничего: на команду .open() - возвращает "-1" и ошибку "Порт недоступен". В чем может быть затык?.. дрова одинаковые возвращает .version() = 10.5.0.0 в обоих случаях. длл-ки лежат в \bin\, зарегены.. делаю без установки параметров .applySingleSettings()..
18. NikNIklas 25.07.19 09:35 Сейчас в теме
(17) а если указать какой порт подключать, то печатает и с сервера... Вопрос: как программно получить настройку в 7ке порта ККМ из параметров?
19. NikNIklas 29.07.19 15:27 Сейчас в теме
еще ситуация: ГТД и код страны передан в ККТ, в ОФД данные по чеку появились, а на самом чеке этих данных нет.. Лог кассы без ошибок. Это Атол 25Ф. При этом 22птк в тестовых режимах печатал всё.
20. NikNIklas 30.07.19 09:52 Сейчас в теме
24. phsin 183 02.08.19 14:12 Сейчас в теме
Стандартные драйвера подружить не удалось, пришлось делать COM обертку... https://infostart.ru/public/1102431/
Оставьте свое сообщение

См. также

Печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54-ФЗ, поддержка изменений от 01/07/19). Для 1С (7.7 и 8 УФ, обычных форм) есть готовые обработки Промо

ККМ Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Абонемент ($m)

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    60961    183    ah7777777    480    

Обработки обслуживания для "ВебЧек: Программный регистратор расчетных операций" (ПРРО)

Кассовые операции Розничная торговля ККМ Фискальный регистратор v7.7 v8 1cv8.cf 1cv7.md Украина Абонемент ($m)

ВебЧек: ПРРО - это программное решение для регистрации расчетных операций, создания электронных чеков на сервере фискальной службы.

1 стартмани

03.03.2020    1562    1    sergoff1    0    

Выставление счета ссылкой на оплату через платежный шлюз Сбербанка из интерфейса 1С

Банковские операции Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Внешняя обработка для выбора документа и формирования ссылки на оплату, которую можно скопировать в буфер обмена и отправить любыми средствами. Совместимо с интернет-эквайрингом Сбербанк.

1 стартмани

14.01.2020    3847    21    etmarket    7    

ККМ в 1С 7.7 через Атол-вебсервер 10.Х

ККМ v77::ОУ 1С7:ТиС Фармацевтика, аптеки Россия Абонемент ($m)

Обработка для работы с Онлайн-ККМ в Е-Фарма 1.2.7 (1С 7.70.027) с помощью Атол-вебсервер 10.Х.

1 стартмани

17.12.2019    1806    3    Vlx    0    

Кассовая книга и архив книг для 1С 7.7 любой конфигурации Промо

Бухгалтерские Закрытие периода Кассовые операции Закрытие периода Кассовые операции v7.7 1cv7.md Россия БУ ИП, ПБОЮЛ, КФХ Абонемент ($m)

Комплекс внешних обработок для удобного ведения в электронной форме кассовой книги формы №КО-4. Все функции редактирования кассовой книги, добавление записей инкассации, сквозная нумерация, печать приходных кассовых ордеров №КО-1 и расходных кассовых ордеров №КО-2. Возможность автоматического заполнения кассовой книги из журнала документов вашей ИБ (любой конфигурации).

5 стартмани

27.04.2015    32556    3    etmarket    11    

Маркировка лекарств: разбор DataMatrix и формирование тега 1162

ККМ v7.7 1cv7.md Фармацевтика, аптеки Россия Абонемент ($m)

В при продаже маркированных лекарственных средств необходимо с упаковки считывать DataMatrix. Выделить из него GTIN и серийный номер упаковки. По алгоритму описанному https://честныйзнак.рф/upload/iblock/09e/09e9978505dad5ba4a8f814420ab20b7.pdf и https://xn--80ajghhoc2aj1c8b.xn--p1ai/upload/iblock/644/Format-zapisi-dannykh-o-vybytii-LP-v-FFD-v2_6.pdf сформировать тег 1162 и пробить чек на онлайн-ккм.

1 стартмани

19.11.2019    4086    11    Vlx    17    

Обработка для ККТ Атол 10.Х

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Оптовая торговля, дистрибуция, логистика Россия БУ Абонемент ($m)

Обработка обслуживания ККТ Атол версии 10.Х в среде 1С 7.7 в ТиС релиз 7.70.998

10 стартмани

24.07.2019    3286    1    _s_y_a_    0    

1С 7.7: Обработка для печати чеков на ККМ ШТРИХ формата ФДД 1.05

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Россия БУ Абонемент ($m)

Обработка позволяет печатать чеки формата ФДД 1.05 на кассовом аппарате ШТРИХ. Проверялась на версиях драйвера 4.14.721 - 749.

1 стартмани

03.04.2019    4864    4    user872794    1    

Штрих-М Онлайн-кассы для 1С 7.7 для новых прошивок с НДС20%

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия НДС Абонемент ($m)

Обработка работает с новыми прошивками касс Штрих-М с НДС20%.

1 стартмани

20.02.2019    6368    16    fugitiveLDN    3    

Обработка обслуживания торгового оборудования. 1С: 7.7 ТиС

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка обслуживания для 1с 7.7 ТиС. Версия драйвера ККТ Атол 8.16.5.9221 Обработка предназначена для корректной передачи СНО при пробитии чека.

1 стартмани

18.01.2019    8682    21    artmaks1988    47    

1С 7.7 ARCUS2 Эквайринговые Терминалы Ingenico (iPP320, iCT250 и т.п.)

POS терминал Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Россия Абонемент ($m)

Использование внешней компоненты для терминалов Ingenico в 1С 7.7. Демо-база с функциями в глобальном модуле и обработкой, демонстрирующей возможности работы с терминалом. Глобальная функция управления терминалом подходит для любой базы данных, предназначенной для расчетов с клиентами. Тестировалась на конфигурациях: Торговля и склад 7.7, Бухгалтерия 7.7 и Упрощенное налогообложение 7.7.

1 стартмани

28.11.2018    6733    20    e-rogov    8    

7.7 ФЗ-54. Печать онлайн чеков на аппаратах Атол прямо из Реализаций без доработок конфигурации. Внешняя печатная форма

Печатные формы документов Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия БУ Абонемент ($m)

Позволяет без доработки ТиС 7.7 настроить печать с онлайн кассы прямо из реализации в виде внешней печатной формы.

1 стартмани

23.08.2018    5799    20    zoeh    0    

Работа с пробитыми чеками по БД Атол

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v7.7 1cv7.md Абонемент ($m)

Получение данных о пробитых чеках по ККМ Атол драйверов версии 8 на ОФД СБИС.

1 стартмани

13.07.2018    7544    1    pakko    7    

Поддержка Онлайн ККМ АТОЛ. Доработка ТиС 7.7 (Бюджетное решение) v 1.0

Кассовые операции ККМ Кассовые операции v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Релиз ТиС 7.70.987. Комплекс позволяет быстро и бюджетно подключить клиенту печать чеков на технике АТОЛ: АТОЛ 30Ф, АТОЛ 55Ф, АТОЛ 22Ф, АТОЛ 52Ф, АТОЛ 11Ф, АТОЛ 90Ф.

1 стартмани

09.07.2018    9033    7    zoeh    6    

54-ФЗ/Онлайн-кассы: Работа с фискальным регистратором на 1С: 7.7

Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 Абонемент ($m)

Конфигурация содержит минимальный функционал для работы с фискальными регистраторами на платформе 1С: 7.7. Если у Вас нет учетной системы, но необходимо соответствовать 54-ФЗ, с минимальными затратами, то эта конфигурация для Вас. Код полностью открыт и распространяется как есть.

10 стартмани

09.06.2018    7539    1    Atom74    0    

Бухгалтерская справка для 1Сv7.7 Бух 4.5

Дебиторская и кредиторская задолженность Кассовые операции Обработка документов Дебиторская и кредиторская задолженность Кассовые операции v77::БУ 1С7:Бух БУ Абонемент ($m)

Внешняя обработка "Бухгалтерская справка" v0.1 (12.01.2018) Вводится на основании документа "Отгрузка товаров, продукции".

1 стартмани

12.01.2018    8489    0    kulkrise    10    

Загрузка в 1С 7.7 УСН 1.3 данных из ОФД о денежных поступлениях (чеках)

Обработка документов Загрузка и выгрузка в Excel Кассовые операции Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Если Ваша торговая точка (ККМ) отделена от 1С 7.7 УСН, а вносить поступление наличных за день в 1С:Бухгалтерию надо, то автоматизировать процесс оформления наличных в 1С:Бухгалтерию можно!

2 стартмани

02.12.2017    12163    5    ah7777777    2    

Групповая печать ПКО и РКО для 1С:Бухгалтерии 7.7

Пакетная печать Кассовые операции Печатные формы документов Кассовые операции v77::БУ 1С7:Бух БУ Абонемент ($m)

Обработка групповой печати ПКО и РКО в 7.7 (2 шт. на одном листе).

1 стартмани

08.11.2017    9366    2    Юлия69    0    

Учет кассы. 1C: 7.7

Управление торговлей Зарплата Кассовые операции Розничная торговля Зарплата Кассовые операции Розничная торговля v7.7 УУ Абонемент ($m)

Простенькая конфигурация на платформе 7.7 для ведения учета денежных средств, заработной платы.

1 стартмани

10.08.2017    10118    0    pafikus0880    0    

Оболочка для работы с последними драйверами ККМ АТОЛ для 1С 7.7, 8.1

Разработка внешних компонент ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Абонемент ($m)

Внешняя компонента - оболочка для работы в среде 1С 7.7 или 1С 8.1 с последними версиями драйверов ККМ от АТОЛ. Поддерживаются драйвера x32 начиная с версии 9.11. Присутствует внешняя обработка для полноценной работы с данными драйверами (поддержка ревизий 2.0, 2.1, 2.2, поддержка протокола ОФД 1.0, 1.0.5, 1.1).

1 стартмани

09.08.2017    34492    288    asdfghgghjdhg    110    

54-ФЗ: Онлайн-касса (кассы). 1С 7.7 + Атол 55Ф ДТО8/10

ККМ Кассовые операции Кассовые операции v7.7 1cv7.md БУ Абонемент ($m)

Обработка ККМ-онлайн для нетиповой 1С:7.7 с печатью на несколько касс. Поддержка тегов 1227,1228. Поддержка версий драйверов ККТ: ДТО8, ДТО10 для Атол. Исходный код открыт.

2 стартмани

23.06.2017    18503    42    vakham    8    

Обработка подключения онлайн-кассы к 1С 7.7 (ПОЛУФАБРИКАТ)

ККМ Кассовые операции Кассовые операции v7.7 1С7:Бух Россия БУ Абонемент ($m)

Обработка обслуживания торгового оборудования для печати чеков ККМ. Протестирована на Конфигурации бухгалтерский учет (7.70.634) с кассой АТОЛ 30 Ф, Печать ПКО и РКО. Также работает на Торговля + Склад.

2 стартмани

31.05.2017    35212    108    Di_Denis    46    

Подключение Онлайн кассы Штрих М к 1С 7.7

Разработка внешних компонент ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Абонемент ($m)

Подключение онлайн кассы Штрих М к любой конфигурации 1С 7.7. Показаны основные приемы работы с драйвером. Обработка представляет из себя набор готовых функций для встраивания в свою конфигурацию: ИнициализироватьФР(); ПодключитьФР(); ОтключитьФР(); ОткрытьСмену(); ЗакрытьСмену(); НапечататьЧек(); АннулироватьЧек(); СнятьХОтчет().

1 стартмани

08.05.2017    22812    75    crimeait    2    

Свод по кассовым документам

Кассовые операции Бухгалтерские Управленческие Кассовые операции v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Отчет формирует сводные данные по документам кассы в различных комбинациях. Два уровня группировки.

1 стартмани

26.01.2017    8218    3    ionfox    0    

Книга учета доходов и расходов (КУДиР) с указанием № Z-отчета в строке

Кассовые операции Бухгалтерские Кассовые операции v77::БУ 1С7:Бух Россия БУ УСН Абонемент ($m)

Налоговая инспекция потребовала в КУДиР в строках учета дохода номера Z-отчетов.

1 стартмани

12.10.2016    10988    5    citicat    7    

Печать кассовой книги для нескольких счетов учета

Кассовые операции Бухгалтерские Кассовые операции v77::БУ 1С7:Бух 1С7:ПУБ Россия БУ Абонемент ($m)

Если в организации касса ведется в разрезе нескольких субсчетов счета 50, то данная обработка позволяет печатать кассовую книгу отдельно на каждый субсчет.

1 стартмани

30.09.2016    6778    1    tany69    1    

Печать штрих-кодов из 1С: 7.7 Комплексная конфигурация

Ценники Рабочее место Кассовые операции Кассовые операции v7.7 1С7:Комплекс 1С7:ТиС Абонемент ($m)

Для тех кто работает на 7 платформе, и не собирается с неё переходить. Стандартная печать этикеток по одной шт за раз совсем даже не интересна. Мне при внедрении штрих кодирования мне помогла обработка

1 стартмани

21.06.2016    21626    4    agent00mouse    5    

Печать документов для Казахстана из Российских конфигураций 1С:7.7 "Комплексная конфигурация ред. 4.5" и "Торговля и Склад ред. 9.2"

Печатные формы документов Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Казахстан УУ Абонемент ($m)

Печатные формы документов Республики Казахстан, адаптированные для 1С:Комплексная конфигурация ред.4.5. Формы утверждены приказом Министра финансов Республики Казахстан от 20 декабря 2012 года №562 (далее Приказ 562).

1 стартмани

20.05.2016    14832    2    aserg    1    

Рабочее место кассира

Рабочее место Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Уникальная внешняя обработка "Рабочее место кассира" для конфигурации Торговля и склад.

3 стартмани

16.09.2015    14729    16    PitMal    3    

Обработка для 1С ТиС 9.2 для работы с ККМ Offline под РМК Штрих-М Кассир 1.*\2.*\5.*

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработки предназначены для 1С: Предприятие 7.7 типовой конфигурации Торговля и Склад 9.2. Сделано несколько существенных изменений по отношению к стандартной обработке Off_spos. И доработана обработка "Загрузка ККМ Off-Line".

1 стартмани

28.08.2015    27403    32        4    

Подключение фискального регистратора MG N707TS, MG-T777TL, MG-T787TL по http (TCP/IP) протоколу JSON

Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Украина Абонемент ($m)

Тестовая конфигурация и пример работы по общению с фискальным регистратором MG N707TS, MG-T787TL, MG-T777TL по HTTP протоколу командами в формате JSON. Обратите внимание, что аппарат может работать и классическим методом по RS232 - подробнее тут http://infostart.ru/public/317286/, но производитель уделяет больше внимания протоколу HTTP JSON (TCP/IP) Добавили еще обработку по работе с кассовым аппаратом MG-V545T по схожему принципу детальнее ... http://infostart.ru/public/530619/ Добавил обработку обслуживания для подключения торгового оборудования. Огромное спасибо ВСЕМ КТО ПОМОГ , участвовал в создании этой обработки.

1 стартмани

09.07.2015    38069    100    mar_a    23    

Обработка для регламентных работ с ФР MG-T808TL

Фискальный регистратор Кассовые операции Кассовые операции v7.7 1cv7.md Украина Абонемент ($m)

Обработка для выполнения регламентных операций с фискальным регистратором MG-T808TL

1 стартмани

01.07.2015    11852    1    maxy3d    2    

Приходный кассовый ордер для 1С 7.7 (Комплексная)

Печатные формы документов Кассовые операции Кассовые операции v7.7 1С7:Комплекс БУ Абонемент ($m)

Внешняя печатная форма ПКО для комплексной конфигурации.

1 стартмани

30.05.2015    12563    3    roketa    1    

Пакетная печать расходных кассовых ордеров в Бухгалтерии 7.7

Пакетная печать Кассовые операции Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Внешняя обработка выводит на печать все расходные кассовые ордера за выбранный период.

1 стартмани

17.05.2015    9133    0    vv-adm    1    

Изменение банковского счета в документах - 1С Бухгалтерия 7.7

Обработка документов Банковские операции Кассовые операции Банковские операции Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Иногда случается, что в справочнике дублируются записи. Это легко поправимо, если дублирующая запись не была использована в документах. В противном случае надо вручную выбирать во всех документах нужный элемент. А если количество документов тысячи - уйдет уйма времени... Данная обработка решает эту проблему! Просто выбрать старый счет (который планируем заменить) и новый (на который заменяем). Полезно.

1 стартмани

02.04.2015    8784    0    program345    9    

Кассовая книга для Альфа-Авто: Автозапчасти+Автосервис 2.0

Бухгалтерские Кассовые операции Кассовые операции v7.7 1cv7.md Автомобили, автосервисы Россия БУ Абонемент ($m)

Внешний отчет Кассовая книга для Альфа-Авто: Автозапчасти+Автосервис 2.0

1 стартмани

03.03.2015    5554    2    aversd    1