Изготовление внешних печатных форм

Публикация № 258450

Разработка - Практика программирования

Создание внешних печатных форм для конфигураций в режиме управляемого приложения

Здравствуйте! На основании одной из тем в разделе программирования я решила дать немного подробный инструктаж по изготовлению  внешних печатных форм для типовых конфигураций.

Если вам нужен макет счета или типового документа, то его можно скопировать из типовой в свою обработку методом: Ctrl+C (Копировать)   Ctrl+V(вставить)

По части регистрации внешней печатной формы приведем пример

Внимание: Работаем в модуле объекта!

Функция СведенияОВнешнейОбработке() Экспорт
// Регистрация ВПФ

//Переменные
ПараметрыРегистрации = Новый Структура;

МассивНазначений = Новый Массив;

//Параметры регистрации
ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");//Вид формы
МассивНазначений.Добавить("Документ.СчетНаОплатуКлиенту");//Привязка к документу, здесь может быть ваш документ
ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
ПараметрыРегистрации.Вставить("Наименование", "НашаПечатнаяФормасчет");//название формы в справочнике внешних обработок
ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);//Безопасный режим включен
ПараметрыРегистрации.Вставить("Версия", "1.0");
ПараметрыРегистрации.Вставить("Информация", "Дополнительная печатная форма к документу СчетНаОплатуКлиенту");

//Добавим команды к форме
ТаблицаКоманд = ПолучитьТаблицуКоманд();
 
ДобавитьКоманду(ТаблицаКоманд, "ИмяКнопки","ИмяМакета","ВызовСерверногоМетода",Истина,"ПечатьMXL");//Кнопке можно дать любое имя,А имя/миноним макета - как назовете макет при создании
ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;

КонецФункции

Функция ПолучитьТаблицуКоманд() 
	Команды = Новый ТаблицаЗначений;
	
Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка")); 
Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); 
Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); 
Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево")); 
Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка")); 
Возврат Команды; 
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование,ПоказыватьОповещение = Ложь, Модификатор = "")

НоваяКоманда = ТаблицаКоманд.Добавить(); 
НоваяКоманда.Представление = Представление; 
НоваяКоманда.Идентификатор = Идентификатор; 
НоваяКоманда.Использование = Использование; 
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение; 
НоваяКоманда.Модификатор = Модификатор; 

КонецПроцедуры 

 По печатным формам можно так же в  поисковике пробить: Технология создания внешних печатных форм.

Для самого простого варианта, если не нужны никакие настройки на форме, то форму можно вообще не создавать и  обработка будет работать из дополнительных Отчетов и Обработок.

Я все таки хочу пояснить немного технологию изготовления собственных макетов

В управляемых формах  введена переменная: МассивОбъектов - она введена для того, чтобы мы могли распечатать одновременно несколько документов и они попадут на печать)

В функцию печати  для управляемых форм передаем как минимум две переменные:

Функция ПечатьДокумента(МассивОбъектов, ОбъектыПечати)

Функция должна называться как угодно, только не Печать() - так как процедура с именем Печать()  уже определена в типовых. Причем  как вспомогательная процедура  из  данных высшего уровня.

1. В типовых  сейчас(как бухгалтерия 3.0 или УТ11) в родных макетах   немного другие понятия в параметрах запроса, в отличие от Бухгалтерии2.0, как:

Для Родных форм

Запрос.УстановитьПараметр("ТекущийДокумент",ЭтотОбъект.Ссылка);

Для внешних печатных форм

Запрос.УстановитьПараметр("ТекущийДокумент",СсылкаНаОбъект);

Для бухгалтерии 3.0 и в том же духе

Запрос.УстановитьПараметр("МассивОбъектов",МассивОбъектов);

При чем  этой переменной можно пользоваться как для  самодельной печатной формы внутри конфигурации, так и для внешней печатной формы.

Приведем пример запроса из бух2.0

Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
	Запрос.Текст =
	"ВЫБРАТЬ
	|	Номер,
	|	Дата,
	|	ДоговорКонтрагента,
	|	Контрагент КАК Получатель,
	|	Организация,
	|	Организация КАК Поставщик,
	|	СуммаДокумента,
	|	ВалютаДокумента,
	|	УчитыватьНДС,
	|	СуммаВключаетНДС
	|ИЗ
	|	Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
	|
	|ГДЕ
	|	РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";
	Шапка = Запрос.Выполнить().Выбрать();
	Шапка.Следующий();

и сделаем тот же запрос в бух.3.0

Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
	Запрос.Текст =
	"ВЫБРАТЬ
	|	Номер,
	|	Дата,
	|	ДоговорКонтрагента,
	|	Контрагент КАК Получатель,
	|	Организация,
	|	Организация КАК Поставщик,
	|	СуммаДокумента,
	|	ВалютаДокумента,
	|	УчитыватьНДС,
	|	СуммаВключаетНДС
	|ИЗ
	|	Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
	|
	|ГДЕ
	|	РеализацияТоваровУслуг.Ссылка В (&МассивОбъектов)";
	Шапка = Запрос.Выполнить().Выбрать();
	Пока Шапка.СледующийПоЗначениюПоля("Ссылка"); 

В обычных формах мы выполнили запрос и приступаем к заполнению документа, на управляемых формах мы сразу же врезаемся в Цикл.

Пока Шапка.СледующийПоЗначениюПоля("Ссылка") Цикл



КонецЦикла

 

И тут выскакивает ошибка: Неверное Значение аргумента!

Ошибка выскакивает, так как мы пытаемся  идти по полю, которого в запросе не существует. В запросе данного поля нет, для устранения ошибки необходимо добавить в запрос Поле: Ссылка

 

Далее в цикле начинаем заполнять данные. Привожу  образец из бухгалтерии 2.0:

 

ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
СведенияОбОрганизации   = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
ПредставлениеПоставщика = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации, "НаименованиеДляПечатныхФорм,");
ОбластьМакета.Параметры.ПредставлениеПоставщика = ПредставлениеПоставщика;
ТабДокумент.Вывести(ОбластьМакета);

 

По сравнению с бухгалтерией 2.0 в бухгалтерии 3.0 все модули поменялись, теперь пример будет таким:

СведенияОПоставщике = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Поставщик, Шапка.Дата);
ПредставлениеПоставщика = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике, "НаименованиеДляПечатныхФорм,");
Область.Параметры.ПредставлениеПродавца = ПредставлениеПоставщика;
ТабДок.Вывести(Область);

 

Пример для Управленияторговлей Ред11:

ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
ПредставлениеПокупателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(Шапка.Покупатель, Шапка.Дата), "ПолноеНаименование");
ОбластьМакета.Параметры.Покупатель = ПредставлениеПокупателя;
ТабличныйДокумент.Вывести(ОбластьМакета);

В функцию СведенияОЮрФизЛице() необходимо передавать  поля  с псевдонимом, какой вы ему присвоили. То есть если в запросе было: ВЫБРАТЬ  Организация КАК Поставщик, то именно Поле с именем Поставщик должно фигурировать в переменной Шапка результата запроса.

Далее   хочу сказать про функцию ФорматСумм();

Бух2.0

ОбщегоНазначения.ФорматСумм(Шапка.СуммаДокумента);

Бухгалтерия3.0 и Торговля11

ОбщегоНазначенияБПВызовСервера.ФорматСумм(Шапка.СуммаДокумента)//Для бухгалтерии 3.0

ФормированиеПечатныхФорм.ФорматСумм(Шапка.СуммаДокумента)//Для Торговли11х

Для ERP2.0  больше функций.

ФормированиеПечатныхФорм.ФорматСумм(Шапка.СуммаДокумента)//Как и в Торговле 11
СуммаПлатежногоДокумента(Сумма, ВыводитьСуммуБезКопеек)//Вывод суммы в рублях без копеек
СуммаРубКоп(Сумма, Валюта, ВалютаРегламентированногоУчета)//Вывод суммы в рублях и копейках

 

 

 

Вывод  ответственных лиц.. уже есть разница  у бухгалтерии 3.0 и Торговле 11, так как в бухгалтерии 3.0  ответственные лица - это регистр сведений, а в управленииТорговлей11 - это справочник. Так же и функционал вывода тоже раскинут по разным модулям

Бухгалтерия 3.0

ОтветственныеЛицаОрганизации = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Организация, Шапка.Дата, Шапка.ПодразделениеОрганизации);
ЗаместительПоПриказу = ОтветственныеЛицаОрганизации.РуководительПредставление;//Или здесь
ПечатьТорговыхДокументов.ЗаполнитьДанныеОтветственныхЛиц(СведенияОДокументе, Новый Структура("ЗаполнятьРуководителя"));
ПечатьТорговыхДокументов.ЗаполнитьДанныеОтветственныхЛиц(СведенияОДокументе, Новый Структура("ЗаполнятьРуководителя"));

 

УправлениеТорговлей ред11х

ОтветственныеЛицаОрганизации = ОтветственныеЛицаСервер.ПолучитьОтветственныеЛицаОрганизации(Шапка.Организация, Шапка.ДатаДок);
ФИОРуководителя = ОтвЛица.Руководитель.Наименование;

Для ERP2.0

ФизическиеЛица.ФамилияИнициалыФизЛица(Выборка.Кассир)//В торговле и ERP2.0
МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
ОтветственныеЛицаСервер.СформироватьВременнуюТаблицуОтветственныхЛицДокументов(МассивОбъектов, МенеджерВременныхТаблиц);// ERP2.0

Функция СформироватьСуммуПрописью() тоже в различных конфигурациях  находится в разных модулях

Бух3.0

СуммаПрописью  = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(СуммаКПрописи, ВалютаРеглУчета);

УТ11

СуммаПрописью  = РаботаСКурсамиВалют.СформироватьСуммуПрописью(Шапка.СуммаДокумента,Шапка.Валюта);

Вывод данных  физических лиц:

ОбластьПодписи.Параметры.Отпустил = ФизическиеЛица.ФамилияИнициалыФизЛица(Шапка.ОтпускПроизвел);//УТ11
МОЛ = ОтветственныеЛицаБП.ОтветственноеЛицоНаСкладе(Шапка.Склад, Шапка.Дата);//Вывод МОЛ для Бух3.0
ДанныеФизЛица = ОбщегоНазначенияБПВызовСервера.ДанныеФизЛица(Шапка.Организация, МОЛ, Шапка.Дата);//Вывод данных физлица для бух3.0

 

Вывод штрихкода на печать для торговли и ERP2.0

ШтрихкодированиеПечатныхФорм.ВывестиШтрихкодВТабличныйДокумент(ТабличныйДокумент, Макет, ОбластьМакета, Выборка.Ссылка);

Вывод номера на печать

ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(Выборка.Номер,Ложь, Истина)//Это в большинстве конфигурация, бух3.0,Торговля11 и ERP2.0

 

Я поработаю над функцией  Формирования печатной формы. Примерно опишу  как я делала свою самодельную печатную форму.

Приведу  пример рисования печатной формы

Создаём  макет типа: ТабличныйДокумент.Перед нами откроется  таблица типа в Экселе

Далее для создания областей выделяем область ячеек(например слева выделяем несколько номеров ячеек), Далее  идем в меню:

Таблица/Имена/Назначить Имя

 

Пишем Имя, например: Заголовок и жмём ОК.

Для данного варианта есть ещё альтернативный пример, выделяя область, жмем комбинации клавиш(Ctrl+Shift+N) - эта комбинация вызывает  ту же команду: НазначитьИмя)

Так мы  можем   создавать   области, которые обычно в стандартных макетах помечаются именами вверху и слева..

Правда если это одна область, тогда

МояОбласть = Макет.ПолучитьОбласть("МояОбласть")

Если  область создана и слева и вверху, и у вас на нужной ячейке  получается   пересечение двух областей, тогда получаем сразу две области:

 

МояОбласть = Макет.ПолучитьОбласть(ГоризонтальнаяОбласть|ВертикальнаяОбласть);

По  теме ячеек...

Если вас не устраивают ячейки в виде таблицы, вы можете выбрать нужное количество ячеек и через Меню: Таблица/Ячейки/Объединить.

Если перестарались, то  там же: Таблица/Ячейки/РазбитьЯчейку.

 

Если вы создали область например слева у вас область, в которую объединено две строки с номерами ячеек и вам их мало, вы бы хотели побольше заголовок? Необязательно пересоздавать область, просто  встаньте на одну из цифр ячеек в области, щелкните по ней правой кнопкой мыши и выберите команду: Раздвинуть. И у вас в области будет не  две, а на три строки высота)))

То же самое касается ячеек в верхней части макета, их точно так же в случае надобности можно разбивать.

Для данных таблиц лучше создавать  две области: Область Шапка(с названиями колонок) и область Строка(с параметрами для заполнения

Создаем ОбластьШапки, выделяем ячейки и щелкаем правой кнопкой Мыши, в контекстном меню ВЫбираем: Свойства

В свойствах есть  такие функции, как: Границасверху,ГраницаСнизу,ГраницаСлева,ГраницаСправа и Обвести..

Для начала, если вам нужна просто колонка для наименования, то много строк там ни к чему. Выбираем колонку в области, выделяем все ячейки колонки и с помощью праволй кнопки мыши в контекстном меню выбираем "Объединить"

У вас получится пустая колонка для размещения текста.

далее в свойствах(так же вызываем через контекстное меню) выбираем нужный функционал

1.ВкладкаОсновные.Текст - там пишем имя колонки, например:Наименование

Далее:

Заполнение: Текст \\оставляем как есть

Использование:Ячейка\\оставляем как есть

Далее есть такакое свойство, как горизонтальное положение и вертикальное положение - выставив вместо АВТО положение ЦЕНТР - вы сделайте наименование колонки в центре.

В Оформлении вы можете сделать побольше шрифт и изменить его свойства.

Границы. Границы вы можете сами задать как вам удобно.Можете по колонке брать и обводить, где поставите границу, там и будет черная черта  при выходе  таблицы в пользовательстком режиме.

 

Заполнение  ставится: Текст - Только для ТекстовыхЗаписей или  если  хотите в пользовательском режиме  внести какой комментарий вручную .

 

Для заполнения  из результатов запроса и прочих переменных,  необходимо свойство заполнения   присвоить значение: Параметр.

Это  чаще всего требуется  при заполнении области Строка, а так же при заполнении  Даты, Номера Документа, вывод дванных кладовщика, Руководителя, Бухгалтера..

Тогда мы можем спокойно заполнять макет так:

МояОбласть.Параметры.ИмяПараметра = ВыборкаЗапроса.НужноеПоле

Живой пример из обработки:

ОбластьТовар.Параметры.Наименование = Товары.Номенклатура;

 

Привожу пример для УТ11

 

Функция СформироватьПечатнуюФормуНакладная(МассивОбъектов, ОбъектыПечати)
    
УстановитьПривилегированныйРежим(Истина);
//Выбираем в запросе чисто те поля, которые нам нужны  для вывода.    

ЗапросШапка = Новый Запрос;
ЗапросШапка.УстановитьПараметр("МассивОбъектов",МассивОбъектов);
ЗапросШапка.Текст = "ВЫБРАТЬ
	|    РеализацияТоваровУслуг.Ссылка КАК Ссылка,
	|    РеализацияТоваровУслуг.Номер КАК Номер,
	|    РеализацияТоваровУслуг.Дата КАК Дата,
	|    РеализацияТоваровУслуг.Партнер КАК Партнер,
	|    РеализацияТоваровУслуг.Контрагент КАК Получатель,
	|    РеализацияТоваровУслуг.Организация КАК Организация,
	|    РеализацияТоваровУслуг.Организация.Префикс КАК Префикс,
	|    РеализацияТоваровУслуг.Валюта КАК Валюта,
	|    РеализацияТоваровУслуг.ЦенаВключаетНДС КАК ЦенаВключаетНДС,
	|    ВЫБОР
	|        КОГДА РеализацияТоваровУслуг.НалогообложениеНДС = ЗНАЧЕНИЕ(Перечисление.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС)
	|                ИЛИ РеализацияТоваровУслуг.НалогообложениеНДС = ЗНАЧЕНИЕ(Перечисление.ТипыНалогообложенияНДС.ПродажаОблагаетсяЕНВД)
	|            ТОГДА ЛОЖЬ
	|        ИНАЧЕ ИСТИНА
	|    КОНЕЦ КАК УчитыватьНДС,
	|    РеализацияТоваровУслуг.Отпустил.Наименование КАК ОтпускПроизвел,
	|    РеализацияТоваровУслуг.СуммаДокумента
	|ИЗ
	|    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
	|ГДЕ
	|    РеализацияТоваровУслуг.Ссылка В(&МассивОбъектов)";
	
//Делаем запрос к табличной части товаров
ЗапросТовары = Новый Запрос;
ЗапросТовары.УстановитьПараметр("МассивОбъектов",МассивОбъектов);
ЗапросТовары.Текст = "ВЫБРАТЬ
	|    РеализацияТоваровУслугТовары.Номенклатура,
	|    РеализацияТоваровУслугТовары.Количество,
	|    РеализацияТоваровУслугТовары.Цена,
	|    РеализацияТоваровУслугТовары.Сумма,
	|    РеализацияТоваровУслугТовары.НомерСтроки,
	|    РеализацияТоваровУслугТовары.Упаковка
	|ИЗ
	|    Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
	|ГДЕ
	|    РеализацияТоваровУслугТовары.Ссылка В(&МассивОбъектов)";

Шапка = ЗапросШапка.Выполнить().Выбрать();
ТабличныйДокумент = Новый ТабличныйДокумент;
ПервыйДокумент = Истина;

Пока Шапка.СледующийПоЗначениюПоля("Ссылка") Цикл
	// Макет необходимо получать для каждого документа,
	//т.к. размеры колонок изменяются динамически
	Макет = ПолучитьМакет("ВПФ_Накладная");
	Если Не ПервыйДокумент Тогда
		ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
	КонецЕсли;

	ПервыйДокумент    = Ложь;
	НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;

	// Выводим шапку накладной
	ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
	ОбластьЗаголовок.Параметры.Номер = Шапка.Номер;
	ОбластьЗаголовок.Параметры.Дата = Шапка.Дата;
	ТабличныйДокумент.Вывести(ОбластьЗаголовок);

	ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
	ПредставлениеПокупателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(ФормированиеПечатныхФорм.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата), "ПолноеНаименование");
	// В скобках выводим Полное наименование, но можно вывести практически всю инфу про организацию, если что требуется, перечислить можно ИНН,КПП, ит.д.  
	ОбластьМакета.Параметры.Покупатель = ПредставлениеПокупателя;
	ТабличныйДокумент.Вывести(ОбластьМакета);

	ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
	ТабличныйДокумент.Вывести(ОбластьШапкаТаблицы);


	//Здесь  можно пользоваться хоть Выборкой, хоть  таблицей значений, но все же лучше рекомендуется выборка.
	// Выводим строки таблицы Товары
	ОбластьТовар = Макет.ПолучитьОбласть("Строка");
	Товары = ЗапросТовары.Выполнить().Выбрать();
	Пока Товары.Следующий() Цикл
		ОбластьТовар.Параметры.КолВо = Товары.Количество;
		ОбластьТовар.Параметры.Наименование = Товары.Номенклатура;
		ОбластьТовар.Параметры.НомСтроки = Товары.НомерСтроки;
		ОбластьТовар.Параметры.Сумма = Товары.Сумма;
		ОбластьТовар.Параметры.Цена = Товары.Цена;
		ОбластьТовар.параметры.ЕдИзм = Товары.Упаковка; 
		ТабличныйДокумент.Вывести(ОбластьТовар);
	КонецЦикла; 
	 
	ОбластьПодписи = Макет.ПолучитьОбласть("Подписи");
	// Выводим Сумму прописью
	ОбластьПодписи.Параметры.СуммаИтог = ФормированиеПечатныхФорм.ФорматСумм(Шапка.СуммаДокумента, Шапка.Валюта);
	ОбластьПодписи.Параметры.СуммаПрописью  = РаботаСКурсамиВалют.СформироватьСуммуПрописью(Шапка.СуммаДокумента, Шапка.Валюта);
	ТабличныйДокумент.Вывести(ОбластьПодписи); 
КонецЦикла;

ТабличныйДокумент.АвтоМасштаб = Истина; 
Возврат ТабличныйДокумент;

КонецФункции

 

Главное правило, следить за перемнными, чтобы не было перменных с одинаковым названием. Если вы уже один раз получили значение перменной, то потом чтобы ею воспользоваться, не надо её получать второй раз. Главное не потерять из виду.

Обработка в вложении для экспериментов.

Отладчик внешних печатных форм можно скачать тут

Обработка для тестирования внешней печатной формы

 

Информация будет добавляться по мере  надобности)

 

 

 

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. AnryMc 721 12.02.14 18:07 Сейчас в теме
Для "лентяев"

Конструктор внешних печатных форм NEW beta (обычные и управляемые приложения!)

http://infostart.ru/public/162019/
JohnConnor; artbear; TrinitronOTV; +3 Ответить
3. TrinitronOTV 3 12.02.14 18:36 Сейчас в теме
(1) AnryMc, я пользуюсь обработкой, которая по ссылке указана, очень помогает быстро сделать внешнюю печатную форму
2. sudmorsh 55 12.02.14 18:12 Сейчас в теме
4. artbear 1174 19.02.14 11:04 Сейчас в теме
Опять старые баяны описываем. Таких статей на сайте уже с десяток, наверное
Aspire1C; ZOMI; +2 Ответить
5. Bukaska 131 19.02.14 11:06 Сейчас в теме
(4) artbear, На сайте баянов с десяток по части регистрации разве что, подробнее не видала.. скидывайте ссылки
7. AnryMc 721 19.02.14 15:21 Сейчас в теме
(4) artbear,

"Повторение - мать учения"
"Новое - хорошо забытое старое"
...
6. sdn-1 146 19.02.14 14:55 Сейчас в теме
Несущественное замечание к оформлению макетов:

На картинке публикации в шапке не очень хорошо смотрится, когда существуют разрывы между ячейками (как в тексте: Накладная№_______НомерДокумента_____от_____ДатаДокумента)

Для улучшения смотрибельности - можно ячейке макета установить заполнение - Шаблон и в самой ячейке заполнить текст примерно так: <Накладная № [Номер] от [Дата]> - в таком случае некрасивых разрывов не будет.

в остальном - спасибо, публикация полезная
8. vicmos 42 19.02.14 17:09 Сейчас в теме
9. Odinas 21.02.14 09:24 Сейчас в теме
Да ладно, именно такой подробной и хорошо оформленной статьи тут не видел. Так что ставлю плюс.
10. higs 11.03.14 07:42 Сейчас в теме
А мне понравилось изложение материала, хоть и практически все уже известно. И кое-что делаю сам не так, но очень интересно было почитать, какие еще есть варианты и ход действий для создания ВПФ. Так что спасибо за подробное разжевывание! А то как вспомню начало работы в 8.3 и как раз с создания ВПФ. У кого-то это будут вовсе даже и не грабли, а ровная дорога.
11. Styvi 6 28.05.14 10:39 Сейчас в теме
Полезная статья для новичков... - ставим плюс...
Вот бы ещё собрать в одно место изменения в реквизитах после рестайлинга конфигураций, а также в названиях Процедур общих модулей... Иногда совершенно непонятно, зачем было менять Наименование реквизита или объекта, если смысл полностью сохранился...
Я часто занимаюсь переносом данных между базами по ОЛЕ и по ходу дела корректирую имена реквизитов в обработках обмена...
Например, в БП3.0 по сравнению с БП2.0:
- в документе РеализацияТоваровУслуг удалён реквизит УчитыватьНДС;
- Справочник КлассификаторСтранМира стал именоваться СтраныМира;
- реквизит Номенклатуры БазоваяЕдиницаИзмерения именуется ЕдиницаИзмерения и т.д.
...
- процедура заполнения счетов учёта в строке ТЧ документа РТУ вместо "Док.ЗаполнитьСчетаУчетаВСтрокеТабЧасти(НоваяСтрокаДока, "Товары", Истина)" будет выглядеть уже так:
СчетаУчета = БухгалтерскийУчетПереопределяемый.ПолучитьСчетаУчетаНоменклатуры(Организация, НоваяСтрокаДока.Номенклатура, НовыйДок.Склад, НовыйДок.Дата, Ложь);
НоваяСтрокаДока.СчетУчета=СчетаУчета.СчетУчета;
НоваяСтрокаДока.СчетДоходов=СчетаУчета.СчетДоходов; и т.д.
...
Rastate; e-kash; Bukaska; +3 Ответить
Оставьте свое сообщение

См. также

Краткое руководство по внесению изменений в конфигурацию

Статья Программист Нет файла v8 1cv8.cf Абонемент ($m) Практика программирования

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    6953    14    sapervodichka    34       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Полезные процедуры и функции для программиста

Статья Программист Нет файла v8 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    16669    7    HostHost    25       

Описание формата внутреннего представления данных 1С в контексте обмена данными

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Разработка

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    9068    7    Dementor    27       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Конвейер проверки качества кода

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования Математика и алгоритмы

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    11316    17    Stepa86    44       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Вам нравятся запросы в 1С?

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    13358    4    m-rv    86       

1С:Ассемблер. Немного летнего веселья!

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    19253    57    Evil Beaver    116       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Простые примеры сложных отчетов на СКД

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    19239    17    Hatson    22       

Безопасная работа с транзакциями во встроенном языке

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    20814    8    tormozit    44       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    18841    77    Synoecium    40       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Отладка сложных отчетов на СКД

Отчеты и формы Программист Расширение (cfe) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    18383    69    maxx    58       

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере"

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    16625    12    dmitry1975    31       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Использование подсистемы БСП "Заполнение объектов"

Статья Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Применение механизмов БСП для добавления новых команд заполнения к формам различных объектов. Использование расширений конфигурации для доработки. Шаблоны для реализации собственных команд заполнения.

1 стартмани

23.11.2018    17621    10    ids79    23       

Работа с публикациями "Инфостарт"

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    12304    12    RocKeR_13    16       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    21970    38    dsdred    13       

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    19241    25    informa1555    26       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Работа с данными выбора

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    28974    17    kalyaka    16       

HTTP Сервисы: Путь к своему сервису. Часть 1

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    52309    23    dsdred    24       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    22393    86    m-rv    57       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    33231    31    dsdred    36       

Как выполнить отчет на СКД через COM и получить данные отчета?

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    20646    11    wowik    3       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Работа со схемой запроса

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    33439    77    kalyaka    34       

Заполняем по шаблону (по умолчанию)

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    20191    20    mvxyz    17