Добавляем дополнительные колонки в обработку Диадок

Публикация № 1763706 07.12.22

Интеграция и обмен данными - ЭДО и ОФД

Добавляем дополнительные колонки в обработку Диадок через подключаемый модуль.

Через подключаемый модуль можно добавить до 5 дополнительных колонок.

Сгенерируем шаблон с событием ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов, будем обрабатывать типовой результат.

 

 

 

В шаблоне добавим новое событие ПолучитьНастройкиДополнительныхКолонокСпискаДокументов

 

 

Функция ОбработатьСобытие(ИмяСобытия, Параметры) Экспорт 
	
	Если ИмяСобытия = "ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов" Тогда

		Возврат ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов(Параметры);	

	ИначеЕсли ИмяСобытия = "ПолучитьНастройкиДополнительныхКолонокСпискаДокументов" Тогда

		Возврат ПолучитьНастройкиДополнительныхКолонокСпискаДокументов(Параметры);

	КонецЕсли;

КонецФункции

 

В функции ПолучитьНастройкиДополнительныхКолонокСпискаДокументов опишем название колонок и тип данных который будет в ней. Для примера колонку "Подразделение 1с" я буду заполнять реквизитом из документа, а колонку "Проверен" из дополнительных сведений.

 

 

Функция ПолучитьНастройкиДополнительныхКолонокСпискаДокументов(Параметры) 
	
	Режим = Параметры.Режим;       
	
	Если Режим = "ОтправкаПакетов" Тогда
		

	    ДопКолонки = Новый Массив;  // не более 5. Индекс элемента в массиве, увеличенный на единицу, совпадает с порядковым номером колонки  
		ДопКолонки.Добавить(Новый Структура("Заголовок, Тип, ДопустимыеЗначения", "Подразделение 1с", Новый ОписаниеТипов("СправочникСсылка.СтруктураПредприятия")));
		ДопКолонки.Добавить(Новый Структура("Заголовок, Тип, ДопустимыеЗначения", "Проверен", Новый ОписаниеТипов("Булево")));
		

	    Возврат ДопКолонки;

	КонецЕсли;
	
КонецФункции 

 

Теперь в событии ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов нужно изменить основной запрос.

 

 

Функция ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда   
		
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "Документ.СверкаВзаиморасчетов КАК АктСверкиВзаиморасчетов","Документ.СверкаВзаиморасчетов КАК АктСверкиВзаиморасчетов"+
		ДобавитьСоединениеВТекстЗапроса("АктСверкиВзаиморасчетов"));    
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "Документ.СчетФактураВыданный КАК СчетФактура","Документ.СчетФактураВыданный КАК СчетФактура"+
		ДобавитьСоединениеВТекстЗапроса());   
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "Документ.СчетФактураВыданныйАванс КАК СчетФактура","Документ.СчетФактураВыданныйАванс КАК СчетФактура"+
		ДобавитьСоединениеВТекстЗапроса());	
		
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "СчетФактура.Ссылка КАК Документ,","СчетФактура.Ссылка КАК Документ,"+ДобавитьДопРеквизит("СчетФактура"));  
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "СчетФактура.Ссылка,","СчетФактура.Ссылка,"+ДобавитьДопРеквизит("СчетФактура"));
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "АктСверкиВзаиморасчетов.Ссылка КАК Документ,","АктСверкиВзаиморасчетов.Ссылка КАК Документ,"+ДобавитьДопРеквизит("АктСверкиВзаиморасчетов","КА_Подразделение",Истина));  
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "АктСверкиВзаиморасчетов.Ссылка,","АктСверкиВзаиморасчетов.Ссылка,"+ДобавитьДопРеквизит("АктСверкиВзаиморасчетов","КА_Подразделение",Истина));                    
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "СчетНаОплатуПокупателю.Ссылка КАК Документ,","СчетНаОплатуПокупателю.Ссылка КАК Документ,"+ДобавитьДопРеквизит("СчетНаОплатуПокупателю","КА_Подразделение"));
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "СчетНаОплатуПокупателю.Ссылка,","СчетНаОплатуПокупателю.Ссылка,"+ДобавитьДопРеквизит("СчетНаОплатуПокупателю","КА_Подразделение"));  
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "ВТ_ДокументыБезНДС.Документ,","ВТ_ДокументыБезНДС.Документ,"+ДобавитьДопРеквизит());  
		Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "ВТ_СчетФактурыПоОтчетуКомиссионера.Документ КАК Документ,","ВТ_СчетФактурыПоОтчетуКомиссионера.Документ КАК Документ,"+ДобавитьДопРеквизит());
		
				
		Возврат Параметры.Результат_ИМ;	
	КонецЕсли;

КонецФункции 

 

Функцией ДобавитьСоединениеВТекстЗапроса добавляем соединение к нужным документам у которых есть свойство "проверен".

Функцией ДобавитьДопРеквизит добавляем поля, если у документа нет этих полей, то все равно нужно добавить пустые поля.

 

 

Функция ДобавитьСоединениеВТекстЗапроса(Док="")  
		
	Если ЗначениеЗаполнено(Док) Тогда 
		 Текст = "
		|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
		|		ПО "+Док+".Ссылка = ДополнительныеСведения.Объект
		|			И (ДополнительныеСведения.Свойство.Имя = ""Проверен_3b08a7c02cad4b2182ef936461881e24"")"; 
	КонецЕсли;	
	
	Возврат Текст;

КонецФункции

Функция ДобавитьДопРеквизит(Док="",Реквизит1="Подразделение",Реквизит2=Ложь)
	
	Если не ЗначениеЗаполнено(Док) Тогда
		Возврат "
			|"""" КАК ДопРеквизит1,
			|"""" КАК ДопРеквизит2,";	
	Иначе	
		Возврат "
			|"+Док+"."+Реквизит1+" КАК ДопРеквизит1,
			|"+?(Реквизит2,"ЕСТЬNULL(ДополнительныеСведения.Значение, ЛОЖЬ)","""""")+" КАК ДопРеквизит2,";   
	КонецЕсли;	

КонецФункции

 

Результат

 

 

Тестировал: 

  • 1С:Комплексная автоматизация 2 (2.4.13.209)
  • Платформа 1С:Предприятие 8.3 (8.3.19.1467)

Диадок:

  • Версия модуля: 4.24.1.2093
  • Версия плагина: 1.4.5.286
  • Расположение модуля: ВСправочнике
  • Модуль интеграции: ПМ_УТ_11

Скачать файлы

Наименование Файл Версия Размер
ДиадокПодключаемыйМодуль

.epf 5,95Kb
4
.epf 5,95Kb 4 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. aleks.public 07.12.22 14:49 Сейчас в теме
Спасибо за статью, интересно

Не подскажете - в какую сторону копать, если надо сделать для маркетплейса подмену в УПД - вместо артикула надо отправлять ШК ?
2. John_d 4365 07.12.22 15:13 Сейчас в теме
(1) событие ПослеПодготовкиПакета
Если ТипЗнч(Параметры.Пакет.Документы) = Тип("Массив") Тогда 
			СлужебнаяИнформация = Параметры.Пакет.Данные1С;  
			
			Для Каждого Стр Из Параметры.Пакет.Документы Цикл
				
				СсылкаНаДокумент = Стр.Документ1С;
				Протоконтент	 = Стр.Content;
				ТипКонтента		 = Стр.ТипКонтента;



КолTable = Протоконтент.Table.Items.Количество();
		Для Ном = 0 По КолTable-1 Цикл
			Товары1 = Протоконтент.Table.Items[Ном];
Товары1.Unit		= "test";
Показать
aleks.public; +1 Ответить
3. John_d 4365 07.12.22 15:17 Сейчас в теме
(2) чтобы понять какие поля нужно менять в Протоконтент. Посмотрите мою статью об отладке infostart.ru/1c/articles/1247892/
aleks.public; +1 Ответить
10. aleks.public 10.01.23 07:04 Сейчас в теме
4. Sergafan10 07.12.22 15:42 Сейчас в теме
(1) отлавливать ИмяСобытия = "ПодготовитьЭлектронныйДокумент", готовить Content, а потом его ковырять
Для Каждого Item Из Items Цикл
 Item.Артикул = ....
КонецЦикла;
5. John_d 4365 07.12.22 16:10 Сейчас в теме
(4) я бы делал в событии ПослеПодготовкиПакета
6. malikov_pro 1211 07.12.22 19:03 Сейчас в теме
Вопрос по варианту доработки: в пакете в XML приходит только сч. фактура (акт в PDF), в итоге создается только сч. ф. вх.
В какой процедуре оптимально перехватывать для создания реализации?
8. kai068 5 08.12.22 10:27 Сейчас в теме
(6) там есть обработка события
ИначеЕсли ИмяСобытия = "ПолучитьЗаполненныйОбъектДокумента1С" , думаю в ней можно создать реализацию.
7. kai068 5 08.12.22 10:22 Сейчас в теме
Статья полезная.
Возможно ли отправлять конкретную УПД через Дополнительный модуль в составе конфигурации, не вызывая обработку КонтурДиадок?
Если можно, то откуда начать?
9. John_d 4365 08.12.22 10:28 Сейчас в теме
(7) посмотрите (17) комментарий в этой статье infostart.ru/public/1737685/ возможно это ваш случай.
11. nLozanikov 10.01.23 11:46 Сейчас в теме
Почему для заполнения колонок вы не выбрали событие "ПослеОбновленияСпискаДокументов"?
Оставьте свое сообщение

См. также

Групповая отправка актов сверки взаиморасчетов через ЭДО

Взаиморасчеты ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Заканчивается очередной квартал, полугодие, год! Возникает необходимость сделать сверку с контрагентами. Есть документ в конфигурации "Акт сверки взаиморасчетов". Представьте, сотни контрагентов и по каждому необходимо создать отдельный документ, задача та еще. А при этом еще сдача отчетности поджимает. Благо есть куча обработок здесь для группового формирования актов сверок. Это существенно сокращает время, но их ведь еще нужно и доставить контрагентам любым из доступных способов. Самый доступный - это отправка по ЭДО.

1 стартмани

26.12.2022    993    6    kras_71    1    

Групповая выгрузка и загрузка файлов XML для ЭДО в каталог по приказу №820 ФНС (для УТ11, КА2, ERP2, БП3, УНФ). Поддержка маркировки

Документооборот и делопроизводство ЭДО и ОФД Файловый обмен (TXT, XML, DBF), FTP Обмен с ГосИС Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Управление нашей фирмой 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Групповая выгрузка файлов XML для ЭДО в каталог по приказу №820 ФНС для Контур.Диадок, СБИС и других провайдеров ЭДО. Поддержка УНФ 1.6, УНФ 3.0

1 стартмани

15.12.2022    1172    11    itcorpru    11    

Создание Поступления на основе XML файлов из Диадок для БП 3.0

ЭДО и ОФД Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Очень часто приходят поступления с маркировками или без в сервис ЭДО ДИАДОК, в таком случае приходится как-то вести учет в этом хорошем добром сервисе, и чтобы иметь возможность вести также у себя, не обязательно покупать ключи разработчика или интеграцию, есть обычная обработка, которая считывает архив с УПД.

10 стартмани

13.12.2022    1004    1    kucar_ip    1    

Расчеты с контрагентами с группировкой по головной организации (БГУ 2)

Взаиморасчеты ЭДО и ОФД Анализ учета Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия государственного учреждения Бухгалтерский учет Бухгалтерский учет Бюджетный учет Бюджетный учет Абонемент ($m) Абонемент ($m)

Здравствуйте. Все с той же пьесы, при использовании ЭДО, при создании электронного документа поставщика, не заполнялся контрагент, оказывается, что если КПП отличается от контрагента в базе и контрагента, от которого прислан документ, то эти данные не заполняются, как и договор. Создав структуру нужных контрагентов (головной офис и куча обособок), при формировании отчета с контрагентами, отчет отображает или по всем контрагентам (без отбора), или необходимо указывать конкретного контрагента (обособленное подразделение), хотя удобно было бы сверять данные по головной организации. Поэтому и сделал этот отчет.

3 стартмани

29.11.2022    926    0    VID1234    0    

Заполнение подписантов ЭДО

ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия государственного учреждения Бюджетный учет Бюджетный учет Абонемент ($m) Абонемент ($m)

Здравствуйте. При внедрении в БГУ 2.0 ЭДО появилась необходимость в быстром заполнении подписантов при выборе маршрута подписания. Можно, конечно, задать маршрут подписания, но для большинства документов подписанты являются переменными (ЦМО) и создавать кучу маршрутов подписания (для каждого), нецелесообразно, конечно, если МОЛов немного, 2-5, то это еще нормально, но если их 20-50 и к тому же для разных видов операций свои комиссии, то это уже неудобно. Поэтому на формы выбора подписантов я добавил кнопку, при нажатии на которую заполняются подписанты, указанные в документе.

3 стартмани

23.11.2022    1010    2    VID1234    0    

Выгрузка документов в формате XML для загрузки в ЭДО операторов СБИС, Диадок и т.п.

Адаптация типовых решений Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Россия Россия Абонемент ($m) Абонемент ($m)

Расширение для добавления дополнительного функционала в библиотеку БЭД , добавляет команду для выгрузки данных в формате XML для загрузки в ЭДО из 1С.

3 стартмани

30.06.2022    3318    35    osa92    14    

Импорт данных из ОФД-Я в отчет о розничных продажах по API

Кассовые операции Розничная торговля WEB-интеграция ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Позволяет импортировать данных из ОФД-Я в отчет о розничных продажах по API, создавая документ "Отчет о розничных продажах". Полезна для бухгалтеров с удаленными кассами или кассами, не подключенными к сервисам 1С.

1 стартмани

15.06.2022    1298    0    kj6370    3    

Получение данных по API с 1-ОФД. Шаблон для загрузки в 1С

Кассовые операции WEB-интеграция ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Получить данные о кассах, сменах, товарах, продажах и возвратах по API 1-ОФД (1-OFD.RU) - не проблема!

1 стартмани

21.04.2022    2037    7    g_b    3    

Автоматизация перепродажи маркированного товара

Розничная торговля ЭДО и ОФД Обмен с ГосИС Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Расширение предназначено для тех организаций, которые перепродают маркированный товар без приемки товара на склад и возможности просканировать штрихкоды с использованием ЭДО СБИС (Тензор).

2 стартмани

18.04.2022    2444    3    arshanskiyav    0    

Подписание и отправка документа через API СБИС ЭДО

ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 Россия Россия Абонемент ($m) Абонемент ($m)

Пример подписания и отправки документа через API СБИС (СБИС.ЗаписатьДокумент, СБИС.ВыполнитьДействие).

2 стартмани

22.02.2022    2931    23    winapi    0    

Реализация с кодами маркировки через ЭДО в Рознице 2.3

Оптовая торговля Розничная торговля Документооборот и делопроизводство ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Россия Россия Абонемент ($m) Абонемент ($m)

Расширение для возможности формировать и отправлять через ЭДО УПД с маркированными товарами по документу "Реализация".

2 стартмани

27.01.2022    4804    45    boba13    36    

Автоматическая отправка документов "Счет покупателю" в формате PDF через ЭДО

Документооборот и делопроизводство Оптовая торговля ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Абонемент ($m) Абонемент ($m)

Расширение  предназначено для автоматической отправки документов «Счет на оплату покупателю» в формате PDF через ЭДО штатными механизмами конфигурации. Расширение для автоматической отправки документов «Счет покупателю» в формате PDF через ЭДО.

10 стартмани

19.01.2022    4058    19    sevarm    15    

Инструменты разработчика для работы с ЭДО СБИС ExtSdk2

Оптовая торговля Документооборот и делопроизводство ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Несколько обработок, которые помогут разработчикам в автоматизации рабочих мест бухгалтеров и менеджеров продаж.

1 стартмани

25.12.2021    5296    29    bobylev1980    4    

Пример конвертации кода маркировки (шины) в Base64 для отправки в ОФД и утилита для конвертации в обратную сторону

Розничная торговля ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Пример конвертации марки в Base64 для отправки в ОФД для шинной продукции. Будет полезно тем, кто работает с маркировкой и у кого не списывается марка в честном знаке.

1 стартмани

22.12.2021    2184    15    Sanek    0    

Загрузка документов из ОФД

Обработка документов Загрузка и выгрузка в Excel Банковские операции Кассовые операции ЭДО и ОФД Бухгалтерский учет Бухгалтерский учет 8.3.14 8.3.14 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Предлагается обработка загрузки документов ПКО, РКО, Операция по платежной карте в конфигурацию Бухгалтерия предприятия из файла выгрузки ексель из Контур ОФД.

1 стартмани

15.11.2021    3880    16    trest30    20    

Загрузка Отчета о розничных продажах из файла ОФД (Сбис) в 1С: Бухгалтерию 3.0

Обработка документов Розничная торговля Загрузка и выгрузка в Excel ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Расширение позволяет создавать документ отчет о розничных продажах из файла excel о продажах выгруженного из Сбис. При загрузке создается документ с наименованием номенклатуры, ценой и количеством.

6 стартмани

04.08.2021    6407    35    lettitbit    20    

Регистрация документов для массовой отправки по ЭДО

Документооборот и делопроизводство Обработка документов ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Интерфейс раздела «Текущие дела ЭДО» служит для формирования, отправки, массовой отправки, подписания, утверждения, приема приглашений, перенаправления на другого пользователя и т.д. Но после обновления модуля ЭДО до версии 1.9.2.19 возникли сложности с МАССОВОЙ ОТПРАВКОЙ документов. До тех пор пока 1С не исправит некорректную работу модуля, можно воспользоваться внешней обработкой для регистрации документов для массовой отправки документов по 1С:ЭДО.

1 стартмани

10.07.2021    4062    12    olym    0    

Автоматическое создание документов Отчет о розничных продажах (ОРП), Выемка из ККМ и ПКО из файла Excel, полученного от оператора фискальных данных (ОФД), для 1С:Розница

Кассовые операции Розничная торговля Загрузка и выгрузка в Excel ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Абонемент ($m) Абонемент ($m)

Обработка позволяет автоматически создать отчеты о розничных продажах, выемку денег из ККМ и приходные кассовые ордера на основании файла, подготовленного из отчета оператора фискальных данных.

10 стартмани

17.06.2021    3581    2    wilduser    0    

Маршрутизация входящих документов, полученных через Оператора ЭДО

Документооборот и делопроизводство ЭДО и ОФД Бухгалтерский учет Бухгалтерский учет 8.3.14 8.3.14 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Переход на электронный документооборот вносит свои коррективы в работу организации. Одна из задач, которые необходимо решить в процессе перехода - определение ответственного по документу в общем потоке входящих электронных документов. При использовании бумажного документооборота этот процесс является привычным, разбор входящей корреспонденции идет по «проторенной» дорожке. А вот с появлением ЭДО часто возникает желание автоматизировать процесс разбора входящих электронных документов. Об автоматизации и пойдет речь в этом посте.

3 стартмани

06.04.2021    8010    3    user594530_abeille89    7    

Выгрузка файлов ЭДО в Ozon из УТ 11 вместе с ГТД

Документооборот и делопроизводство Оптовая торговля ЭДО и ОФД Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 Оперативный учет Оперативный учет 1С:Управление торговлей 11 1С:Управление торговлей 11 Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Это дополнение к системе 1С позволяет выгружать файлы УПД или ТОРГ-12 с данными гтд и кодами странам в формате XML напрямую из системы 1С УТ 11. Выгруженные файлы вы сможете отправлять Ozon в системе электронного документооборота Контур.Диадок.

1 стартмани

09.02.2021    4602    13    solaru    1    

Пример работы с API СБИС ЭДО

ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Пример авторизации, получения информации по документам, закрытия сессии. Обработка подойдет для тех, у кого возникли проблемы с подключением к сервису из 1С.

2 стартмани

08.12.2020    8861    74    winapi    13    

Удаление электронных документов (ЭДО) у помеченных на удаление документов

Документооборот и делопроизводство Чистка данных Обработка документов ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка находит помеченные на удаление документы, у которых есть движения по ЭДО. Помечает на удаление все объекты ЭДО, связанные с этими документами.

1 стартмани

05.10.2020    7133    37    rokhin    11    

Загрузка выручек касс по API с 1-ОФД (1-OFD.RU)

Обработка документов Кассовые операции ККМ Розничная торговля WEB-интеграция ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Абонемент ($m) Абонемент ($m)

Обработка позволяет формировать отчеты о розничных продажах средствами API с 1-ОФД (1-OFD.RU)

2 стартмани

18.09.2020    7036    11    ketr    6