Стандартная свертка базы 1С:Розница не работает? Тогда вам сюда

Публикация № 1723109 07.09.22

Администрирование БД - Свертка базы

свертка чистка базы удаление документы размер розница

В публикации рассмотрен механизм свертки базы в один клик или по расписанию на начало предыдущего месяца.

Пара продовольственных розничных магазинов генерируют в год примерно 100 тысяч документов и миллионы записей регистров. Типовая свертка может продлиться 1 день и еще дольше будут удаляться помеченные на удаление документы. Если настроена распределенная база данных, то обмен тоже не будет работать до окончания прохождения огромных сообщений с удаленными объектами. А что делать магазинам несколько дней?

Если 1С:Розница используется как кассовая программа, то есть учет ведется в вышестоящей товароучетной системе (например, 1С:Управление торговлей), то свертку можно проводить почаще. Например, раз в месяц, оставляя документы за последний месяц.

Приложенная обработка производит следующие операции:

- удаляет непосредственно все документы ЧекККМ, а также все документы движений в регистры ТоварыНаСкладах, ЦеныНоменклатуры, БонусныеБаллы датой до начала предыдущего месяца (если запускаем 05.09.2022, то удаляются документы до 01.08.2022 00:00:00);

 

 

- формирует документ начальных остатков Корректировка регистров только по регистрам ТоварыНаСкладах, ЦеныНоменклатуры, БонусныеБаллы датой за секунду до начала предыдущего месяца (если запускаем 05.09.2022, то Корректировка регистров с датой 31.07.2022 23:59:59);

 

 

- создает лог-файл в папке C:\temp.

 

 

Внимание! Действия обработки необратимы! В обработке используется непосредственное удаление документов. Копия базы обязательна перед использованием!

Тестировалось на платформе 1С версии 8.3.21.1302, демо-базе конфигурации 1С:Розница версии 2.3.11.44. Код модуля объекта обработки представлен ниже.


#Область ПрограммныйИнтерфейс

Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");
	
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
	ПараметрыРегистрации.Версия = "22.09.05";
	
	Разрешение = РаботаВБезопасномРежиме.РазрешениеНаИспользованиеКаталогаВременныхФайлов(Истина, Истина, "Обработка использует временное хранилище.");
	ПараметрыРегистрации.Разрешения.Добавить(Разрешение);
	
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Свертка базы'");
	НоваяКоманда.Идентификатор = "СверткаБазы";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	Возврат ПараметрыРегистрации;
	
КонецФункции 

Функция ВыполнитьКоманду(Идентификатор, ПараметрыКоманды) Экспорт
	
	Если Идентификатор = "СверткаБазы" Тогда  
		
		СтруктураПараметров = Новый Структура;
		СтруктураПараметров.Вставить("ДатаСвертки", НачалоМесяца(ДобавитьМесяц(ТекущаяДата(), -1)));
		СтруктураПараметров.Вставить("ТолькоПосчитать", Ложь);
		СтруктураПараметров.Вставить("ОтправлятьВТелеграм", Ложь);
		СтруктураПараметров.Вставить("IDПользователяТелеграм", "0"); 
		СоздатьКаталог("C:\temp");
		СтруктураПараметров.Вставить("ПутьКЛогФайлу", "C:\temp\log1c.txt");
		
		СверткаБазы(СтруктураПараметров);
	КонецЕсли;
	
КонецФункции

#КонецОбласти


// Основные процедуры и функции
Процедура СверткаБазы(СтруктураПараметров, Параметр2 = Неопределено) Экспорт
	
	УстановитьДатуСверткиУзлов(СтруктураПараметров.ДатаСвертки);
	
	КорректировкаРегистровСсылка = СформироватьНачальныеОстаткиВажныхРегистров(СтруктураПараметров.ДатаСвертки);
	ЗаписатьЛог("Ввод начальных остатков.",,,СтруктураПараметров.ПутьКЛогФайлу);
	ЗаписатьЛог(Строка(КорректировкаРегистровСсылка), СтруктураПараметров.ОтправлятьВТелеграм, СтруктураПараметров.IDПользователяТелеграм, СтруктураПараметров.ПутьКЛогФайлу);
	
	Запрос = Новый Запрос;
	Запрос.Текст = ПолучитьТекстЗапроса(); 
	
	Запрос.УстановитьПараметр("ДатаСвертки", СтруктураПараметров.ДатаСвертки - 1);
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	ЗаписатьЛог("Кол-во: " + ВыборкаДетальныеЗаписи.Количество(),,,СтруктураПараметров.ПутьКЛогФайлу);
	Если СтруктураПараметров.ТолькоПосчитать Тогда
		Возврат;
	КонецЕсли;
	
	КоличествоУдаленныхДокументов = 0;
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ЗаписатьЛог("Удалено документов " + КоличествоУдаленныхДокументов + " из " + ВыборкаДетальныеЗаписи.Количество()
			,,,СтруктураПараметров.ПутьКЛогФайлу);

		ТекущийОбъект = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
		
		Если ТекущийОбъект = Неопределено Тогда  
			УдалитьДвиженияВажныхРегистров(ВыборкаДетальныеЗаписи.Ссылка); 
			КоличествоУдаленныхДокументов = КоличествоУдаленныхДокументов + 1;
			Продолжить;
		КонецЕсли;   
		
		Если ТипЗнч(ТекущийОбъект) = Тип("ДокументОбъект.КорректировкаРегистров") И 
			ТекущийОбъект.Дата = СтруктураПараметров.ДатаСвертки-1 И 
			ТекущийОбъект.Комментарий = "Свертка" Тогда  
			Продолжить;	
		КонецЕсли; 
		
		ЗаписатьЛог(Строка(ВыборкаДетальныеЗаписи.Ссылка),,,СтруктураПараметров.ПутьКЛогФайлу); 
		
		Попытка 
			
			Для каждого НаборДвижений из ТекущийОбъект.Движения Цикл 
				НаборДвижений.Прочитать();
				Если НаборДвижений.Количество() > 0 Тогда
					НаборДвижений.Очистить();
					НаборДвижений.ОбменДанными.Загрузка = Истина; 
					НаборДвижений.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
					НаборДвижений.Записать();	 
				КонецЕсли;
			КонецЦикла;  
			ТекущийОбъект.ОбменДанными.Загрузка = Истина;
			ТекущийОбъект.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
			ТекущийОбъект.Удалить();
			КоличествоУдаленныхДокументов = КоличествоУдаленныхДокументов + 1;
			
		Исключение
			
			ЗаписатьЛог("====================",,,СтруктураПараметров.ПутьКЛогФайлу);
			ЗаписатьЛог("Ошибка! " + Строка(ВыборкаДетальныеЗаписи.Ссылка),,, СтруктураПараметров.ПутьКЛогФайлу);
			ЗаписатьЛог(ОписаниеОшибки(), СтруктураПараметров.ОтправлятьВТелеграм, СтруктураПараметров.IDПользователяТелеграм, СтруктураПараметров.ПутьКЛогФайлу);
			ЗаписатьЛог("====================",,,СтруктураПараметров.ПутьКЛогФайлу);
			
		КонецПопытки;
		
	КонецЦикла;
	
КонецПроцедуры

Функция ПолучитьТекстЗапроса();
	Возврат "ВЫБРАТЬ
	|	ЧекККМ.Ссылка КАК Ссылка,
	|	ЧекККМ.Дата КАК Период
	|ПОМЕСТИТЬ Документы
	|ИЗ
	|	Документ.ЧекККМ КАК ЧекККМ
	|ГДЕ
	|	ЧекККМ.Дата <= &ДатаСвертки
	|
	|ОБЪЕДИНИТЬ ВСЕ
	|
	|ВЫБРАТЬ
	|	ТоварыНаСкладахОбороты.Регистратор,
	|	ТоварыНаСкладахОбороты.Период
	|ИЗ
	|	РегистрНакопления.ТоварыНаСкладах.Обороты(, &ДатаСвертки, Регистратор, ) КАК ТоварыНаСкладахОбороты
	|
	|ОБЪЕДИНИТЬ ВСЕ
	|
	|ВЫБРАТЬ
	|	БонусныеБаллыОбороты.Регистратор,
	|	БонусныеБаллыОбороты.Период
	|ИЗ
	|	РегистрНакопления.БонусныеБаллы.Обороты(, &ДатаСвертки, Регистратор, ) КАК БонусныеБаллыОбороты
	|
	|ОБЪЕДИНИТЬ ВСЕ
	|
	|ВЫБРАТЬ
	|	ЦеныНоменклатуры.Регистратор,
	|	ЦеныНоменклатуры.Период
	|ИЗ
	|	РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры
	|ГДЕ
	|	ЦеныНоменклатуры.Период <= &ДатаСвертки
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	Документы.Ссылка КАК Ссылка,
	|	Документы.Период КАК Период
	|ИЗ
	|	Документы КАК Документы
	|
	|УПОРЯДОЧИТЬ ПО
	|	Документы.Период";
КонецФункции

Процедура УстановитьДатуСверткиУзлов(ДатаСвертки)
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ПоМагазину.Ссылка КАК Ссылка
	|ИЗ
	|	ПланОбмена.ПоМагазину КАК ПоМагазину
	|
	|ОБЪЕДИНИТЬ ВСЕ
	|
	|ВЫБРАТЬ
	|	ПоРабочемуМесту.Ссылка
	|ИЗ
	|	ПланОбмена.ПоРабочемуМесту КАК ПоРабочемуМесту";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		УзелОбъект = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
		УзелОбъект.ОбменДанными.Загрузка = Истина;
		УзелОбъект.ДатаНачалаВыгрузкиДокументов = ДатаСвертки;
		УзелОбъект.Записать();
	КонецЦикла;
	
КонецПроцедуры

Функция СформироватьНачальныеОстаткиВажныхРегистров(ДатаСвертки)
	
	ДатаНачальныхОстатков = ДатаСвертки - 1;
	
	Если НачальныеОстаткиСозданыРанее(ДатаНачальныхОстатков) Тогда
		Возврат "Начальные остатки созданы ранее!";
	КонецЕсли;
	
	КорректировкаРегистровОбъект = Документы.КорректировкаРегистров.СоздатьДокумент(); 
	КорректировкаРегистровОбъект.Ответственный = Пользователи.ТекущийПользователь();
	КорректировкаРегистровОбъект.Дата = ДатаНачальныхОстатков;
	КорректировкаРегистровОбъект.ОбменДанными.Загрузка = Истина;
	КорректировкаРегистровОбъект.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
	НоваяСтрокаТаблицыРегистров = КорректировкаРегистровОбъект.ТаблицаРегистров.Добавить();
	НоваяСтрокаТаблицыРегистров.Имя = "БонусныеБаллы";
	НоваяСтрокаТаблицыРегистров = КорректировкаРегистровОбъект.ТаблицаРегистров.Добавить();
	НоваяСтрокаТаблицыРегистров.Имя = "ЦеныНоменклатуры";
	НоваяСтрокаТаблицыРегистров = КорректировкаРегистровОбъект.ТаблицаРегистров.Добавить();
	НоваяСтрокаТаблицыРегистров.Имя = "ТоварыНаСкладах";
	КорректировкаРегистровОбъект.Комментарий = "Свертка"; // не менять
	КорректировкаРегистровОбъект.Записать(); 
	
	// Бонусы
	НаборЗаписейБонусы = РегистрыНакопления.БонусныеБаллы.СоздатьНаборЗаписей();
	НаборЗаписейБонусы.Отбор.Регистратор.Установить(КорректировкаРегистровОбъект.Ссылка);
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	БонусныеБаллыОстатки.ДисконтнаяКарта КАК ДисконтнаяКарта,
	|	БонусныеБаллыОстатки.БонуснаяПрограммаЛояльности КАК БонуснаяПрограммаЛояльности,
	|	БонусныеБаллыОстатки.НачисленоОстаток КАК Начислено,
	|	БонусныеБаллыОстатки.КСписаниюОстаток КАК КСписанию
	|ИЗ
	|	РегистрНакопления.БонусныеБаллы.Остатки(&ДатаСвертки, ) КАК БонусныеБаллыОстатки";
	Запрос.УстановитьПараметр("ДатаСвертки", ДатаСвертки);
	
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		НоваяЗапись = НаборЗаписейБонусы.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяЗапись, ВыборкаДетальныеЗаписи);
		Если НоваяЗапись.Начислено < 0 Тогда 
			НоваяЗапись.ВидДвижения = ВидДвиженияНакопления.Расход;
			НоваяЗапись.Начислено = -НоваяЗапись.Начислено;
		КонецЕсли;
		НоваяЗапись.Период = ДатаНачальныхОстатков;
		НоваяЗапись.Регистратор = КорректировкаРегистровОбъект.Ссылка;
	КонецЦикла; 
	НаборЗаписейБонусы.ОбменДанными.Загрузка = Истина;
	НаборЗаписейБонусы.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
	НаборЗаписейБонусы.Записать();
	
	
	// Цены номенклатуры
	НаборЗаписейЦены = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей();
	НаборЗаписейЦены.Отбор.Регистратор.Установить(КорректировкаРегистровОбъект.Ссылка);
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ЦеныНоменклатурыСрезПоследних.ВидЦены КАК ВидЦены,
	|	ЦеныНоменклатурыСрезПоследних.Номенклатура КАК Номенклатура,
	|	ЦеныНоменклатурыСрезПоследних.Характеристика КАК Характеристика,
	|	ЦеныНоменклатурыСрезПоследних.Цена КАК Цена,
	|	ЦеныНоменклатурыСрезПоследних.Упаковка КАК Упаковка,
	|	ЦеныНоменклатурыСрезПоследних.Валюта КАК Валюта
	|ИЗ
	|	РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&ДатаСвертки, ) КАК ЦеныНоменклатурыСрезПоследних";
	
	Запрос.УстановитьПараметр("ДатаСвертки", ДатаСвертки);
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		НоваяЗапись = НаборЗаписейЦены.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяЗапись, ВыборкаДетальныеЗаписи);
		НоваяЗапись.Период = ДатаНачальныхОстатков;
		НоваяЗапись.Регистратор = КорректировкаРегистровОбъект.Ссылка;
	КонецЦикла;
	НаборЗаписейЦены.ОбменДанными.Загрузка = Истина;
	НаборЗаписейЦены.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
	НаборЗаписейЦены.Записать();
	
	
	// Товары на складах
	НаборЗаписейТовары = РегистрыНакопления.ТоварыНаСкладах.СоздатьНаборЗаписей();
	НаборЗаписейТовары.Отбор.Регистратор.Установить(КорректировкаРегистровОбъект.Ссылка);
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ТоварыНаСкладахОстатки.Склад КАК Склад,
	|	ТоварыНаСкладахОстатки.Номенклатура КАК Номенклатура,
	|	ТоварыНаСкладахОстатки.Характеристика КАК Характеристика,
	|	ТоварыНаСкладахОстатки.КоличествоОстаток КАК Количество
	|ИЗ
	|	РегистрНакопления.ТоварыНаСкладах.Остатки(&ДатаСвертки, ) КАК ТоварыНаСкладахОстатки";
	
	Запрос.УстановитьПараметр("ДатаСвертки", ДатаСвертки);
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		НоваяЗапись = НаборЗаписейТовары.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяЗапись, ВыборкаДетальныеЗаписи);
		Если НоваяЗапись.Количество < 0 Тогда 
			НоваяЗапись.ВидДвижения = ВидДвиженияНакопления.Расход;
			НоваяЗапись.Количество = -НоваяЗапись.Количество;
		КонецЕсли;
		НоваяЗапись.Период = ДатаНачальныхОстатков;
		НоваяЗапись.Регистратор = КорректировкаРегистровОбъект.Ссылка;
	КонецЦикла;
	
	НаборЗаписейТовары.ОбменДанными.Загрузка = Истина;
	НаборЗаписейТовары.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
	НаборЗаписейТовары.Записать();
	
	
	Возврат КорректировкаРегистровОбъект.Ссылка; 
КонецФункции

Функция НачальныеОстаткиСозданыРанее(ДатаНачальныхОстатков)
	Результат = Ложь;
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	КорректировкаРегистров.Ссылка КАК Ссылка
	|ИЗ
	|	Документ.КорректировкаРегистров КАК КорректировкаРегистров
	|ГДЕ
	|	КорректировкаРегистров.Дата = &ДатаНачальныхОстатков
	|	И КорректировкаРегистров.Комментарий ПОДОБНО &Комментарий";
	
	Запрос.УстановитьПараметр("ДатаНачальныхОстатков", ДатаНачальныхОстатков);
	Запрос.УстановитьПараметр("Комментарий", "Свертка");
	
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Если ВыборкаДетальныеЗаписи.Следующий() Тогда
		Результат = Истина;
	КонецЕсли;
	
	Возврат Результат;
КонецФункции

Процедура УдалитьДвиженияВажныхРегистров(Ссылка)
	
	Попытка
		НаборЗаписейБонусы = РегистрыНакопления.БонусныеБаллы.СоздатьНаборЗаписей();
		НаборЗаписейБонусы.Отбор.Регистратор.Установить(Ссылка);
		НаборЗаписейБонусы.ОбменДанными.Загрузка = Истина;
		НаборЗаписейБонусы.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
		НаборЗаписейБонусы.Записать(); 
	Исключение
	КонецПопытки;
	
	Попытка
		НаборЗаписейЦены = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей();
		НаборЗаписейЦены.Отбор.Регистратор.Установить(Ссылка);
		НаборЗаписейЦены.ОбменДанными.Загрузка = Истина;
		НаборЗаписейЦены.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
		НаборЗаписейЦены.Записать();
	Исключение
	КонецПопытки;
	
	Попытка
		НаборЗаписейТовары = РегистрыНакопления.ТоварыНаСкладах.СоздатьНаборЗаписей();
		НаборЗаписейТовары.Отбор.Регистратор.Установить(Ссылка);
		НаборЗаписейТовары.ОбменДанными.Загрузка = Истина;
		НаборЗаписейТовары.ДополнительныеСвойства.Вставить("ОтключитьМеханизмРегистрацииОбъектов");
		НаборЗаписейТовары.Записать();
	Исключение
	КонецПопытки;
	
КонецПроцедуры

// Вспомогательные процедуры и функции
Процедура ЗаписатьЛог(Строка, ОтправитьВТелеграм = Ложь, IDПользователяТелеграм = "", ПутьКЛогФайлу)
	СтрокаКЗаписи = Строка(ТекущаяДата()) + ": " + Строка; 
	
	Если ОтправитьВТелеграм Тогда
		ОтправитьВТелеграм(СтрокаКЗаписи, IDПользователяТелеграм);		
	КонецЕсли;
	
	Файл = Новый ЗаписьТекста(ПутьКЛогФайлу,,,Истина);
	Файл.ЗаписатьСтроку(СтрокаКЗаписи);
	Файл.Закрыть();
	
	Сообщить(СтрокаКЗаписи);
КонецПроцедуры

Процедура ОтправитьВТелеграм(СтрокаКЗаписи, IDПользователяТелеграм);
// отправка в телеграм
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Стандартная свертка базы 1С:Розница не работает? Тогда вам сюда.:

.epf 7,16Kb
3
.epf 7,16Kb 3 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Корректировка остатков регистров бухгалтерии (обычные и управляемые формы) Промо

Свертка базы Чистка данных Закрытие периода Корректировка данных Платформа 1С v8.3 Платформа 1C v8.2 Бухгалтерский учет Управляемые формы Конфигурации 1cv8 Бухгалтерский учет Налоговый учет Абонемент ($m)

Внешняя обработка, предназначенная для удобного исправления остатков по регистрам бухгалтерии (Хозрасчетный, Налоговый или любой другой) посредством автоматизации ввода корректировочного документа ("Операция", "Корректировка записей регистров"), приводящего регистр в нужное состояние остатков от текущего. Удобна для массовых правок остатков по бухгалтерскому и налоговому учету на какую-то дату (обычно перед реорганизацией учета, сверткой базы и т.п.)

2 стартмани

03.06.2017    44659    275    stvorl    29    

Свертка остатков по любому счету в ручную операцию для БП 3

Свертка базы Корректировка данных Платформа 1С v8.3 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Обработка позволяет свернуть остатки по любому счету бухучета, по организации и на любую дату в программе БП 3 и создать ручную операцию с корреспонденцией на 000.

2 стартмани

26.08.2022    498    2    taramaz    0    

Свертка 10 счета по партиям

Свертка базы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Обработка сворачивает остатки по пустым партиям 10-го счета. Обработка формирует проводки документом Операция, созданным пользователем.

10 стартмани

22.08.2022    462    0    vik77    0    

Свертка Бухгалтерии предприятия 3.0 на любую дату

Свертка базы Платформа 1С v8.3 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Данная обработка/расширение поможет свернуть базу Бухгалтерии предприятия 3.0 на любой месяц и день, в то время как типовая обработка "Свёртка информационной базы" позволяет свернуть базу только на начало года.

1 стартмани

05.07.2022    907    13    darminov    1    

Корректировка остатков регистров накопления (обычные и управляемые формы) Промо

Свертка базы Чистка данных Универсальные обработки Закрытие периода Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Внешняя обработка, предназначенная для удобного и быстрого исправления остатков регистров накопления (посредством автоматического ввода документов "Корректировки записей регистров", "Операция", содержащих движения, приводящие существующие остатки к желаемым). Позволяет корректировать и обнулять по аналитике и суммам остатки регистров учета товаров, партий, взаиморасчетов, налогового учета по НДС, РАУЗ, и др.

2 стартмани

14.01.2012    95343    1854    stvorl    81    

Свертка больших баз через выгрузку - загрузку остатков

Свертка базы Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

У вас большая база - больше 300 гб, и вы хотите её уменьшить? В стандартных процедурах свёртки возникают ошибки или не хватает памяти? Вы хотите перегнать огромные списки остатков между базами? Тогда, возможно, данная разработка будет вам интересна.

2 стартмани

18.05.2022    1558    8    dima1c    13    

Свертка цен для БП 3.0

Свертка базы Обработка документов Ценообразование, анализ цен Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

История изменения записывается в созданный документ "Установка цен номенклатуры".

1 стартмани

14.02.2022    2369    1    Tarlich    2    

Свертка сальдо

Свертка базы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Обработка для свертки сальдо по счету при нулевом остатке по контрагенту

1 стартмани

13.01.2022    2070    11    user821472    3    

Переход с УСН на ОСНО. Формирование остатков НУ и данных по регистру затрат УчетЗатратРегл (РАУЗ) Промо

Свертка базы Универсальные обработки Склад и ТМЦ Платформа 1С v8.3 1С:Комплексная автоматизация 1.х Россия Налоговый учет Абонемент ($m)

Не знаете, как побороть сообщение "движения сформировались без суммовой оценки" при проведении документов после перехода на ОСНО - эта обработка для вас. Обработка выполняет закрытие остатков по счетам учета ТМЦ и формирование новых остатков на заданную пользователем дату с проверкой итоговых сумм и количества по БУ и НУ, а также закрытие остатков по старым ключам аналитики (без применения счетаНУ) и формирование новых остатков. Для конфигурации Комплексная Конфигурация 1.1

10 стартмани

30.01.2014    35262    12    buy_sale    7    

Свертка регистров накопления блока ЖКХ, для программы 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК 3.0. Вводит начальные остатки по регистрам накопления с видом Остатки на дату свертки

Свертка базы Платформа 1С v8.3 Конфигурации 1cv8 Энергетика и ЖКХ Россия Абонемент ($m)

Обработка, выполняющая свертку регистров накопления ЖКХ (с префиксом КВП и УПЖКХ) для конфигурации 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК 3.0. Документы, выполняющие движения до даты свертки, помечаются на удаление.

1 стартмани

13.01.2022    2519    3    kas1989    3    

Исправление неправильных остатков при свертке базы Бухгалтерии

Свертка базы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Данное исправление подойдет вам, если обработка свертки считает неправильные остатки.

1 стартмани

06.12.2021    2703    15    awp234    2    

Свертка регистров сведений перед удалением измерений

Свертка базы Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка, которая позволяет увидеть, какие записи регистра сведений задублируются при удалении указанных измерений, и вручную или автоматически удалить ненужные записи регистра для возможности обновления конфигурации после изменения структуры регистра сведений.

1 стартмани

06.09.2021    2644    17    frkbvfnjh    0    

Очистка регистров накопления, сведений, расчета или бухгалтерии Промо

Чистка данных Свертка базы Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Очистка регистров накопления, сведений, расчета или бухгалтерии (обычная и управляемая форма)

2 стартмани

25.12.2009    73675    1246    sebe    20    

Свертка базы БП 3.0 на дату

Свертка базы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Стандартная свертка обрабатывает базу только на 01.01, в этой обработке дату свертки можно указать.

1 стартмани

22.07.2021    4016    53    stdstd    2    

Универсальная сверка данных между разными базами 1С через веб-сервис

Свертка базы Обмен между базами 1C Платформа 1С v8.3 Платформа 1C v8.2 Платформа 1С v8.1 Конфигурации 1cv8 Абонемент ($m)

Сверяем данные. Механизм был создан для проверки корректности проведённой свёртки базы, хотелось сравнить свёрнутую облегчённую базу, где были удалены старые данные и введены остатки - с копией до работ. Базы большие, копия находилась на другом сервере, поэтому пришлось организовать сверку и сравнение данных по сети (через SOAP-вебсервис).

2 стартмани

21.07.2021    6491    24    METAL    5    

Сжатие картинок в хранилище дополнительной информации для УТ 10.3 и УПП

Свертка базы Платформа 1С v8.3 Платформа 1C v8.2 1С:Управление торговлей 10 1С:Управление производственным предприятием Управленческий учет Абонемент ($m)

Обработка уменьшения размера картинок JPG, хранящихся в информационной базе для сжатия размера ИБ и сайта магазина.

1 стартмани

11.05.2021    4668    13    amatoravg    9    

Свертка БП 2.0 документами Ввод начальных остатков Промо

Свертка базы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 2.0 Россия Бухгалтерский учет Налоговый учет Абонемент ($m)

Обработка свертки БП 2.0 по оригинальному алгоритму - рассчитываются остатки на выбранную дату, создаются документы "Ввод начальных остатков". Затем эти документы выгружаются в файл XML и загружаются в чистую базу. Обороты за период (документы и операции) после свертки также через XML переносятся в новую базу. В отличие от "стандартного" алгоритма (которого для БП 2.0 на сегодняшний день нет, или я про него не знаю) требует гораздо меньшего времени на осуществление самой свертки - не надо помечать на удаление документы, ждать их окончательного удаления и нет необходимости упаковки базы через тестирование и исправление. Время, необходимое на обработку результатов свертки, зависит в первую очередь от корректности ведения учета в исходной базе. Большая просьба ко всем, кто решится на её использование, описать возникшие проблемы, если они проявятся - постараюсь исправить. Новая версия для свертки 2.0 или 3.0 в 3.0 - http://infostart.ru/public/509628/ Огромное спасибо всем откликнувшимся!!!

2 стартмани

24.02.2012    127709    4072    Alex_E    741    

Свертка регистра "Цены номенклатуры" для УТ

Свертка базы Платформа 1С v8.3 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Абонемент ($m)

Замутил обработку, которая найдет такие товары, по которым нет установки цен в регистре после даты свертки, получит по ним срез последних на дату свертки.

2 стартмани

30.04.2021    4387    2    VPanin56    4    

Свертка базы УТ 11.4

Свертка базы Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Работающий вариант типовой свёртки базы УТ 11.4.6.207.

1 стартмани

12.03.2021    5134    29    DnsRzv    4    

Обнуление остатков по указанным регистрам документа и указанным значениям измерений

Свертка базы Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка помогает обнулить остатки по указанным регистрам и указанным значениям измерений. Указываем документ, который участвовал в формировании остатков для обнуления, отмечаем регистры, отмечаем список измерений, получаем полный список регистров, проверяем отбор по этим измерениям, формируем движения регистров, которые обнулят остатки по этим регистрам с выбранным отбором.

1 стартмани

28.02.2021    3935    20    rokhin    2    

Свертка 60, Свертка 62, Исправление ошибок взаиморасчетов, Исправление 60, Исправление 62 Промо

Свертка базы Корректировка данных Анализ учета Взаиморасчеты Оборотно-сальдовая ведомость, Анализ счета Платформа 1С v8.3 1С:Бухгалтерия 2.0 Россия Бухгалтерский учет Абонемент ($m)

Исправляет все возможные ошибки по счетам расчетов с контрагентом, делает дебетовое сальдо на активном счете и кредитовое на пассивном. кроме того зачитывает все суммы по контрагенту и договору. Сворачивает 60 и 62 счета. Умеет работать с документами взаиморасчетов или без них.

1 стартмани

21.10.2010    44174    682    GoodWinSpr    37    

Свертка базы 1С:Розница 2

Свертка базы Платформа 1С v8.3 1С:Розница Россия Управленческий учет Абонемент ($m)

Свертка базы 1С:Розница 2.3 - порядок действий и обработка-помощник.

1 стартмани

16.02.2021    8105    32    ptkrzy    0    

Типовая обработка по свертке ЕРП. Возможные проблемы и их решение

Свертка базы Платформа 1С v8.3 1С:ERP Управление предприятием 2 Управленческий учет Абонемент ($m)

Добрый день, коллеги. Хочу рассказать про опыт использования типовой обработки свертки ЕРП.  А именно про ряд ошибок, которые могут встречаться в типовой обработке свертки ЕРП.

1 стартмани

04.02.2021    4544    17    Andrei_Ivanov    0    

Свертка базы на любую дату типовой обработкой для 1С:Бухгалтерии 3.0

Свертка базы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Налоговый учет Абонемент ($m)

Расширение для конфигурации 1С: Бухгалтерия 3.0 позволяет использование любой даты в типовой обработке "Свёртка информационной базы", а не только - начало года.

1 стартмани

16.12.2020    7151    46    kumi2012    14    

Свертка информационной базы для конфигурации "Бухгалтерия предприятия КОРП 3.0"

Свертка базы Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Типовая обработка переделана, можно указывать определенную дату.

2 стартмани

02.06.2020    5319    13    wowik    1    

Создание копии рабочей базы

Свертка базы Архивирование (backup) Платформа 1С v8.3 Абонемент ($m)

Как регулярно создавать копии рабочей базы для разработки? Как уменьшить объём тестовой базы? Как получать всегда актуальную тестовую базу?

1 стартмани

28.05.2020    11132    22    imm0rtal    0    

Сжатие (уменьшение размера) файлов изображений 1С без внешних компонент - для любой конфигурации на основе БСП > 2.3

Свертка базы Универсальные обработки Платформа 1С v8.3 1С:Розница 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Если в базу загружено большое количество изображений, картинок, фото товаров, размером более 2-3МБ, то в базе будут сильно тормозить все процессы, связанные с чтением-передачей файлов изображений: формирование прайса, отчетов с картинками, выгрузка изображений товаров на сайт и т.д. Данная обработка позволяет провести оптимизацию (уменьшение размера) загруженных картинок в базу 1С любой конфигурации на основе БСП >= 2.3 стандартными средствами 1С, сохраняя при этом достаточно хорошее качество сжатых картинок. Проверено на релизе УТ 11.4.11.71, для обработки понадобится также версия Платформы 1С >= 8.3.14.

1 стартмани

08.03.2020    17588    122    1sig    34    

Свертка базы и очистка таблиц

Свертка базы Чистка данных Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Обработка написана с использованием БСП. Встраивается как внешняя. Работает в фоне. Позволяет средствами SQL очищать выборочно таблицы с настройками, заданными привычным образом через отбор СКД.

5 стартмани

05.03.2020    12731    57    YAGolova    8    

Корректный перенос Заказов покупателей (предыдущих периодов) при использовании обеспечения и переходе в течение года КА 1.1 (УТ 10.3) + Правила переноса КА 1.1 - УТ 11.4

Обмен между базами 1C Свертка базы Обработка документов Оперативный учет 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

В процессе перехода с использованием разработанных правил (на основании стандартной обработки), я столкнулся с проблемой некорректного поведения Заказов покупателей/Заказов поставщику. При вводе переходящих с прошлых периодов Заказов покупателей/Заказов поставщику уже приобретенные/реализованные товары не учитываются при вводе на основании. Предлагаю решение данной проблемы.

3 стартмани

25.02.2020    7825    12    Leoon    1    

Присоединение одной организации к другой - слияние. Создание и замена ссылок одной организации на другую

Свертка базы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Вашему вниманию процесс присоединения баланса одной организации к другой. Процесс объединения может быть использован на любых конфигурациях, где используется обработка Свертка информационной базы. Обработка Копирование и замена ссылок универсальна и может найти применение в других прикладных задачах - выполняет копию ссылки с заменой всех реквизитов, использующих организацию(легко переделывается на другой объект) на заданную. С помощью Свертки мы получаем остатки по регистрам на дату слияния. Далее этих остатки нужно заменить организацию, для чего мы используем обработку копирования с заменой. Мы осуществляли переход на БП 3.0.75.37.

2 стартмани

27.12.2019    8392    21    DennyPhilord    2    

Сворачивание остатков регистра Себестоимость товаров по развернувшейся аналитике Аналитика финансового учета. ERP

Свертка базы Платформа 1С v8.3 1С:ERP Управление предприятием 2 Управленческий учет Абонемент ($m)

ERP, Сворачивание остатков регистра СебестоимостьТоваров по развернувшейся аналитике АналитикаФинансовогоУчета. Проявляется это следующим образом: При выполнении регламентной операции по закрытию месяца, на шаге Расчет себестоимости не возникает проблемы по регистру ТоварыОрганизации, но возникают "остатки нераспределенных материальных затрат в регистре "Себестоимость товаров"".

1 стартмани

18.12.2019    12617    69    rokhin    0    

Свертка базы на любую дату для 1С:Бухгалтерия 3.0

Свертка базы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Данная обработка позволяет свернуть базу бухгалтерии на любой месяц и день, в то время как типовая обработка "Свёртка информационной базы" позволяет свернуть базу только на начало года.

2 стартмани

13.12.2019    10627    119    Aleksandr55555    5    

Групповое удаление документов 8.2 (обычная форма) любая конфигурация

Свертка базы Чистка данных Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Абонемент ($m)

Удаление выборочных видов документов в обратном порядке. Для всех конфигураций 8.х

2 стартмани

14.10.2019    8151    36    wolder    3    

Сброс неудачной свертки базы. УТ 11.х

Свертка базы Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Обработка позволяет сбросить неудачную Свертку базы УТ 11.x и запустить ее заново.

1 стартмани

17.09.2019    9827    68    S_Mit    0    

Свертка регистра накопления

Свертка базы Платформа 1С v8.3 1С:Управление производственным предприятием Абонемент ($m)

Данная обработка предназначена для свертки регистра накопления с остатками до определенной даты.

1 стартмани

22.08.2019    10587    47    mmitin    3    

Универсальная свертка остатков по счетам расчетов с контрагентами для "1С:Бухгалтерия 3.0"

Свертка базы Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Универсальная свертка остатков по счетам расчетов с контрагентами для конфигурации "1С:Бухгалтерия 3.0"

2 стартмани

23.07.2019    12324    118    vvadim    6    

Малый набор для обрезки(свертки,очистки) баз

Свертка базы Чистка данных Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Набор для облегчения ряда работ связанных с обрезкой (сверткой,очисткой) баз

1 стартмани

17.07.2019    8759    49    Бит    0    

Свертка базы 1С

Свертка базы Платформа 1С v8.3 Россия Абонемент ($m)

Конфигурация «Свертка базы 1С» Основное назначение конфигурации - настраиваемая свертка базы 1С. Процесс свертки выглядит следующим образом: 1. Пользователь определяет параметры соединения информационной базы 2. Пользователь указывает объекты свертки и дату свертки 3. Конфигурация соединяется с базой посредством com-соединения и по настройкам начинает удалять объекты 4. Для анализа и контроля свертки добавлен отчет

2 стартмани

09.06.2019    12265    45    ring_andrey    17    

Свертка базы УНФ 1.6

Свертка базы Платформа 1С v8.3 1С:Управление нашей фирмой Россия Абонемент ($m)

В УНФ 1.6 не предусмотрена штатная свертка базы. Эта обработка сворачивает базу.

2 стартмани

08.02.2019    19738    234    artfa    43    

Свертка количества и сумм по складам и номенклатуры (после свертки базы)

Свертка базы Склад и ТМЦ Платформа 1С v8.3 Бухгалтерский учет 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление производственным предприятием Бухгалтерский учет Абонемент ($m)

Обработка по сворачиванию сумм и количества по номенклатуре и складам в документе Операция (бухгалтерский и налоговый учет).

1 стартмани

08.02.2019    8431    2    Teut_Vlad    0    

Свертка информационной базы для УТ 11.4 (исправлена ошибка регистра накопления Расчеты по договорам кредитов и депозитов)

Свертка базы Платформа 1С v8.3 Оперативный учет Управляемые формы 1С:Управление торговлей 11 Россия Абонемент ($m)

Внешняя обработка "Помощник свертки информационной базы" для УТ 11.4. Исправлена ошибка РегистрНакопления.РасчетыПоДоговорамКредитовИДепозитов.Остатки ИЗ РегистрНакопления.РасчетыПоДоговорамКредитовИДепозитов.Остатки(&ГраницаОст) КАК ТабРег

1 стартмани

18.01.2019    17941    183    user732170    31    

"Легкие" правила переноса остатков из БП 3.0 в БП 3.0 (Свертка базы документами "Ввод остатков")

Обмен между базами 1C Свертка базы Файловые протоколы обмена (TXT, XML, DBF), FTP Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Налоговый учет Абонемент ($m)

Публикация содержит в себе правила переноса остатков из конфигурации Бухгалтерия 3.0 в конфигурацию Бухгалтерия 3.0. Правила могут быть полезны для свертки рабочей базы документами "Ввод начальных остатков" или для перехода из типовой Бухгалтерии в отраслевую конфигурацию, основанную на ней.

1 стартмани

15.12.2018    37544    590    Skin123    104    

Свертка регистра "Зарплата к выплате"

Зарплата Свертка базы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Сворачивает записи по регистру "Зарплата к выплате" на определенную дату (предполагается конец прошлого года). Чтобы при заполнении ведомости по зарплате не вылезали долги за прошлые периоды.

1 стартмани

26.10.2018    11518    49    AndKovalchuk    12