Повторяющиеся логины пользователей

Публикация № 1179080

Администрирование - Информационная безопасность - Роли и права

В этой статье хочу предложить для рассмотрения небольшую но полезную обработку, которая работает в режиме внешней обработки и выявляет задвоенные логины пользователей. Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854.

Задача возникла в результате того, что я работаю в специфической организации,
где часто идет ротация пользователей(
например аудиторы заходят или фискалы, за раз до 50-60 пользователей). В результате довольно
частая ситуация появляются в базе пользователи с одинаковыми логинами и их надо отлавливать периодически.
Эта обработка дает возможность это делать, плюс парочка дополнительных
возможностей, просмотр всех пользователей и просмотр работающих пользователей. Обработка используется на практике. 

 

Представляю скриншоты которые показывают три закладки на форме обработки:

 

1. Отображены все пользователи

2. Отображены двойные логины

3. Отображены работающие пользователи

Программа запускается как внешняя обработка:

&НаКлиенте
Процедура ПриОткрытии(Отказ)

		ОбработкаСписка();

КонецПроцедуры

    На форме обработки имеется кнопка "Инструкция", которая запускает процедуру ИнструкцияПоЭксплуатации(Команда):

&НаКлиенте
 Процедура ИнструкцияПоЭксплуатации(Команда)
//Процедура выводит текстовый файл Инструкция по эксплуатации     
    Инструкция="          Инструкция на обработку двойной логин."+Символы.ПС+" 
    |1. На закладке ""Все пользователи"" отображаются все пользователи базы."+Символы.ПС+"
    |2. На закладке ""Двойные логины"" отображаются пользователи с повторяющимися логинами (выбираются только действующие пользователи)."+Символы.ПС+"
    |3. На закладке ""Список рабочих пользователей"" отображаются только действующие пользователи";
    
    Предупреждение(Инструкция);
    
КонецПроцедуры

    Следующая процедура заполняет три закладки, которые указаны выше на скриншотах.
Подробно работа процедуры описана в комментариях.

&НаСервере
Процедура ОбработкаСписка()
		ТаблицаСписокПользователей.Очистить();
		ТаблицаДействующихПользователей.Очистить();
		ПорядковыйНомер=0;
		
		//Создаем Массив пользователей Информационной Базы для изменения доменов *****************************
		Выборка= ПользователиИнформационнойБазы.ПолучитьПользователей();                           //Получаем массив пользователей и  из массива выбираем нужного пользователя по идентификатору
		Для Каждого ЭлементМассива Из Выборка Цикл
			ПолноеИмяПользователя=ЭлементМассива.ПолноеИмя;                                        //Из массива забираем полное имя пользователя
			ПользовательУникльныйИдентификатор=ЭлементМассива.УникальныйИдентификатор;             //Из массива забираем уникальный идентификатор пользователя
			ДоменЛогин=ЭлементМассива.ПользовательОС;                                              //Из Массива забираем домен логин пользователя
			
			Запрос = Новый Запрос;                                                                 //Определяем текущего пользователя в справочнике Пользователи 
			Запрос.Текст = 
			"ВЫБРАТЬ
			|	Пользователи.Наименование КАК Наименование,
			|	Пользователи.ПометкаУдаления КАК ПометкаУдаления
			|ИЗ
			|	Справочник.Пользователи КАК Пользователи
			|ГДЕ
			|	Пользователи.ИдентификаторПользователяИБ = &ПользовательУникльныйИдентификатор"
			;
			Запрос.УстановитьПараметр("ПользовательУникльныйИдентификатор",ПользовательУникльныйИдентификатор);
			РезультатЗапроса = Запрос.Выполнить();
			Выборка = РезультатЗапроса.Выбрать();                                
			Пока Выборка.Следующий() Цикл
				Если Выборка.ПометкаУдаления=Ложь Тогда
					ПометкаУдаленияПользователя = "Действует";                                       //Записываем результат ПометкаУдаления
				Иначе
					ПометкаУдаленияПользователя = "Удален";
				КонецЕсли;		
			КонецЦикла; 
			
			//****************************************************************************************************				  
			Если НЕ	ДоменЛогин="" Тогда		                                                         //Выделяем из ДоменЛогин Домен и логин
				ДлинаДомена=СтрДлина(ДоменЛогин);
				ДоменПользователя="";
				ЛогинПользователя="";
				Буква="";
				СчетчикБукв=3;
				Буква=Сред(ДоменЛогин,СчетчикБукв,1);
				ФлагДЛ="Д";
				Пока СчетчикБукв <= ДлинаДомена Цикл
					Если Буква="\" Тогда
						ФлагДЛ="Л";
						СчетчикБукв=СчетчикБукв+1;
						Буква=Сред(ДоменЛогин,СчетчикБукв,1);
					Иначе
						Если ФлагДЛ="Д" Тогда
							ДоменПользователя=ДоменПользователя+Буква; 
							СчетчикБукв=СчетчикБукв+1;
							Буква=Сред(ДоменЛогин,СчетчикБукв,1);  
						КонецЕсли;
						Если ФлагДЛ="Л" Тогда
							ЛогинПользователя=ЛогинПользователя+Буква; 
							СчетчикБукв=СчетчикБукв+1;
							Буква=Сред(ДоменЛогин,СчетчикБукв,1);  
						КонецЕсли;
					КонецЕсли;
				КонецЦикла;
			Иначе
				ЛогинПользователя="";
				ДоменПользователя="";
			КонецЕсли;
//***************************************************************************************************************************************************
//Заносим в таблицу всех пользователей по списку*****************************************************************************************************
			ПорядковыйНомер=ПорядковыйНомер+1;
			Строка=ТаблицаСписокПользователей.Добавить(); 
			Строка.ПорядковыйНомер=ПорядковыйНомер;
			Строка.ПолноеИмяПользователя=ПолноеИмяПользователя;                               
			Строка.ПользовательУникльныйИдентификатор =ПользовательУникльныйИдентификатор;
			Строка.ДоменЛогин=СокрЛП(ДоменЛогин);
			Строка.ДоменПользователя =СокрЛП(ДоменПользователя) ;
			Строка.ЛогинПользователя =СокрЛП(ЛогинПользователя) ;
			Строка.ПометкаУдаления=ПометкаУдаленияПользователя;
		КонецЦикла;
		ПорядковыйНомер=0;
		Запрос = Новый Запрос;
		ТСП = РеквизитФормыВЗначение("ТаблицаСписокПользователей",Тип("ТаблицаЗначений"));           //Выгружаем Табличный реквизит формы в переменную
		МВТ=Новый МенеджерВременныхТаблиц;                                                           //Создаем МенеджерВременныхТаблиц
		Запрос.МенеджерВременныхТаблиц=МВТ;
//Помещаем таблицу пользователей во временную таблицу и из нее выбираем талько рабочих пользователей, помещаем их в таблицу рабочих пользователей****	
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ТСП1.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ТСП1.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ТСП1.ДоменЛогин КАК ДоменЛогин,
		|	ТСП1.ДоменПользователя КАК ДоменПользователя,
		|	ТСП1.ЛогинПользователя КАК ЛогинПользователя,
		|	ТСП1.ПометкаУдаления КАК ПометкаУдаления
		|ПОМЕСТИТЬ ВТПользователи
		|ИЗ
		|	&ТСП1 КАК ТСП1
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	ВТПользователи.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ВТПользователи.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ВТПользователи.ДоменЛогин КАК ДоменЛогин,
		|	ВТПользователи.ДоменПользователя КАК ДоменПользователя,
		|	ВТПользователи.ЛогинПользователя КАК ЛогинПользователя,
		|	Пользователи.Ссылка КАК ПользовательСсылка,
		|	Пользователи.ПометкаУдаления КАК ПометкаУдаления
		|ИЗ
		|	ВТПользователи КАК ВТПользователи
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Пользователи КАК Пользователи
		|		ПО ВТПользователи.ПользовательУникльныйИдентификатор = Пользователи.ИдентификаторПользователяИБ
		|ГДЕ
		|	НЕ Пользователи.ПометкаУдаления = Истина
		|
		|УПОРЯДОЧИТЬ ПО
		|	ПолноеИмяПользователя"
		
		;
		Запрос.УстановитьПараметр("ТСП1",ТСП);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();                                
		Пока Выборка.Следующий() Цикл                                                                 //Выбираем результат запроса в цикле
			ПорядковыйНомер=ПорядковыйНомер+1;
			Строка=ТаблицаСписокРабочихПользователей.Добавить(); 
			Строка.ПорядковыйНомер=ПорядковыйНомер;
			Строка.ПолноеИмяПользователя=Выборка.ПолноеИмяПользователя;                               
			Строка.ПользовательУникльныйИдентификатор =Выборка.ПользовательУникльныйИдентификатор;
			Строка.ДоменЛогин=Выборка.ДоменЛогин;
			Строка.ДоменПользователя =Выборка.ДоменПользователя ;
			Строка.ЛогинПользователя =Выборка.ЛогинПользователя ;
			Строка.ПометкаУдаления =Выборка.ПометкаУдаления ;
		КонецЦикла;
		
//Помещаем таблицу рабочих пользователей во временную таблицу, выбираем пользователей со сдвоенными логинами для этого используем "КОЛИЧЕСТВО"*******
//и одно поле группировки во временную таблицу  СдвоенныеЗаписи . Соединяем временные таблицы и справочник Пользователи******************************
		ПорядковыйНомер=0;
		ЛогинКоличество1=1;
		ТСП = РеквизитФормыВЗначение("ТаблицаСписокПользователей",Тип("ТаблицаЗначений"));           //Выгружаем Табличный реквизит формы в переменную
		МВТ=Новый МенеджерВременныхТаблиц;                                                           //Создаем МенеджерВременныхТаблиц
		Запрос.МенеджерВременныхТаблиц=МВТ;
		
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ТСП1.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ТСП1.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ТСП1.ДоменЛогин КАК ДоменЛогин,
		|	ТСП1.ДоменПользователя КАК ДоменПользователя,
		|	ТСП1.ЛогинПользователя КАК ЛогинПользователя
		|ПОМЕСТИТЬ ВТПользователи
		|ИЗ
		|	&ТСП1 КАК ТСП1
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	ВТПользователи.ЛогинПользователя КАК ЛогинПользователя,
		|	КОЛИЧЕСТВО(ВТПользователи.ЛогинПользователя) КАК СдвоенныеЗаписиКоличество
		|ПОМЕСТИТЬ СдвоенныеЗаписи
		|ИЗ
		|	ВТПользователи КАК ВТПользователи
		|
		|СГРУППИРОВАТЬ ПО
		|	ВТПользователи.ЛогинПользователя
		|
		|ИМЕЮЩИЕ
		|	КОЛИЧЕСТВО(ВТПользователи.ЛогинПользователя) > 1
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	ВТПользователи.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ВТПользователи.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ВТПользователи.ДоменЛогин КАК ДоменЛогин,
		|	ВТПользователи.ДоменПользователя КАК ДоменПользователя,
		|	ВТПользователи.ЛогинПользователя КАК ЛогинПользователя,
		|	СдвоенныеЗаписи.СдвоенныеЗаписиКоличество КАК СдвоенныеЗаписиКоличество,
		|	Пользователи.Ссылка КАК ПользовательСсылка
		|ИЗ
		|	ВТПользователи КАК ВТПользователи
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ СдвоенныеЗаписи КАК СдвоенныеЗаписи
		|		ПО ВТПользователи.ЛогинПользователя = СдвоенныеЗаписи.ЛогинПользователя
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Пользователи КАК Пользователи
		|		ПО ВТПользователи.ПользовательУникльныйИдентификатор = Пользователи.ИдентификаторПользователяИБ
		|ГДЕ
		|	НЕ Пользователи.ПометкаУдаления = ИСТИНА
		|
		|УПОРЯДОЧИТЬ ПО
		|	СдвоенныеЗаписиКоличество,
		|	ДоменЛогин"
		
		;
		Запрос.УстановитьПараметр("ТСП1",ТСП);
		Запрос.УстановитьПараметр("ЛогинКоличество",ЛогинКоличество1);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();                                
		Пока Выборка.Следующий() Цикл                                            //Выбираем результат запроса в цикле
			ПорядковыйНомер=ПорядковыйНомер+1;
			Строка=ТаблицаДействующихПользователей.Добавить(); 
			Строка.ПорядковыйНомер=ПорядковыйНомер;
			Строка.ПолноеИмяПользователя=Выборка.ПолноеИмяПользователя;                               
			Строка.ПользовательУникльныйИдентификатор =Выборка.ПользовательУникльныйИдентификатор;
			Строка.ДоменЛогин=Выборка.ДоменЛогин;
			Строка.ДоменПользователя =Выборка.ДоменПользователя ;
			Строка.ЛогинПользователя =Выборка.ЛогинПользователя ;
			Строка.ЛогинКоличество =Выборка.СдвоенныеЗаписиКоличество ;
			Строка.ПользовательСсылка =Выборка.ПользовательСсылка ;
		КонецЦикла;   
КонецПроцедуры
	

 

Скачать файлы

Наименование Файл Версия Размер
Повторяющиеся логины пользователей.:

.epf 10,56Kb
13.01.20
0
.epf 10,56Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. DJDUH 17 14.01.20 11:44 Сейчас в теме
А консоль 1С чем не подходит? или я не понял смысл этой обработки.
2. bryantsev.yury 31 14.01.20 12:22 Сейчас в теме
(1)Смысл этой обработки следующий:
В реальных базах идет большой оборот пользователей, возникают ситуации
когда появляются пользователи с одинаковыми логинами.
для выявления таких ситуаций была создана эта обработка, плюс дополнительная возможность просмотреть всех пользователей и просмотреть
действующих пользователей.
4. chng 20.05.20 19:21 Сейчас в теме
(2) ИМХО ваша стратегия больбы с проблемой это какойто костыль в попытке устранить последствия, а бороться надо с причиной.
Попробуйте использовать в качестве логина, ФИО полностью и без сокращений! Лучше один раз убедить начальство принять такие правила, чем постоянно ожидать прерывания на устранение этих дублей...
У нас это правило, пользовательИБ=ФИЗ лицо за 6 лет при 4000 сотрудников в зупе, полные однофамильцы (причем не родственники) встретились всего несколько раз.
3. bryantsev.yury 31 14.01.20 12:34 Сейчас в теме
(1) Прошу уточнить какую консоль Вы имеете в виду.
5. bryantsev.yury 31 21.05.20 10:10 Сейчас в теме
chng Вы совершенно правы , это костыль, но пользователь так работает и по
другому работать не хочет, "Клиент всегда прав" или "Маемо, что маемо"
Оставьте свое сообщение

См. также

Просмотр пользователей и их прав - инструмент администрирования

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Позволяет проанализировать Пользователей и их роли. В случае большого количества пользователей быстро понять, какие наборы прав нужны для выполнения заданных целей.

1 стартмани

23.09.2020    344    1    Vardar    7    

Запрет на изменение проведенного документа для УНФ 1.6

Роли и права v8 УНФ Россия Абонемент ($m)

Запрет на изменение проведенного документа Расходная накладная для УНФ 1.6.

2 стартмани

21.09.2020    356    0    Kerim09    0    

Расширение для запрета изменений в документе "Регистрация трудовой деятельности" по дате запрета.

Адаптация типовых решений Роли и права v8 ЗУП3.x Россия Абонемент ($m)

В ЗУП 3.1.14.183 оставлена возможность отменить проведение и провести заново для документа "Регистрация трудовой деятельности" из списка документов, чем сотрудники отдела кадров успешно пользуются. Позже они возмущаются, что появляется несколько одинаковых записей отмены и такая же для отправки по сотруднику в "мероприятиях" при заполнении документа "Сведения о трудовой деятельности работников, СЗВ-ТД". Расширение устанавливает запрет на изменения по общей дате запрета, если нет отдельно по пользователю. Никакие изменения в основную конфигурацию вносить не нужно, просто добавляете расширение.

1 стартмани

07.09.2020    695    0    Svetlanka_sv    0    

Запрет произвольной цены

Расширения Роли и права Ценообразование, анализ цен v8 v8::Права ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

Расширение для запрета произвольной цены в документе Заказ клиента и обработке Подбор товаров в документ продажи.

1 стартмани

06.09.2020    790    1    user1209971    0    

Все объекты, на которые у роли есть право доступа

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Получение всех объектов, на которые у указанной роли есть указанное или хоть какое-то право доступа, в виде дерева метаданных.

1 стартмани

28.08.2020    975    2    Yashazz    4    

Роль "Менеджер по продажам" в Бухгалтерии 3. Даем доступ к документам Поступления, к ОСВ по счету только 41.01 и карточке счета только 41.01

Оптовая торговля Роли и права v8 v8::Права БП3.0 Россия БУ Абонемент ($m)

Расширяем возможности стандартной роли "Менеджер по продажам" в Бухгалтерии 3. Даем доступ к просмотру и редактированию документов Поступление ТМЦ. А также к Оборотно-сальдовой ведомости по счету 41.01 и Карточке счета по счету 41.01.

3 стартмани

26.08.2020    818    2    ah7777777    5    

Массовый перенос ролей пользователей из одной конфигурации в другую

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Данная обработка позволяет получить список текущих ролей всех пользователей 1С или установить роли согласно списку для всех пользователей 1С. Тестировалось на платформе 8.3.15. Привязки к конфигурации нет - любая.

1 стартмани

21.08.2020    1038    1    donpadlo    6    

Настройка панели разделов с помощью Ролей, гибкая настройка начальной Страницы для Бухгалтерии

Роли и права v8::БУ БП3.0 Аудит и бухгалтерские услуги, юриспруденция Россия БУ Абонемент ($m)

Расширение прав с главным приоритетом в 1С Бухгалтерии, если пользователю не нужен "Раздел производства", "Зарплаты и кадры" мы можем их убрать. Можно конечно, убрать через панель навигации каждому пользователю, но это крайне не удобно и пользователь может сам себе вернуть разделы. Так же я столкнулся с БазовымиПравамиБСП, которая дает права на все разделы, а если эту роль исключить то мы получим ошибку при входе(не имеем базовых прав). Как этого избежать?

1 стартмани

06.08.2020    1173    4    Profenix    0    

Пользователи программы

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Отчет по справочнику "Пользователи", соединенный с данными пользователей системы.

1 стартмани

20.07.2020    1646    1    Pro-tone    0    

Анализ прав пользователей в Бухгалтерии предприятия 3.0

Роли и права v8 v8::Права БП3.0 Абонемент ($m)

Наглядное представление прав пользователей со сводкой доступа к организациям.

1 стартмани

14.07.2020    1785    2    wenzor    0    

Подсистема прав доступа к объектам с гибкими отборами (расширение)

Роли и права v8 ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Возможность без доработок конкретизировать пользователям права Просмотра и Изменения объектов базы 1С, установив ограничения с помощью отборов системы компоновки данных.

2 стартмани

02.07.2020    7361    58    sapervodichka    38    

Доступ к функционалу ЭДО пользователя без администраторских прав

Документооборот и делопроизводство Роли и права v8 v8::Права УНФ Абонемент ($m)

Данная обработка предназначена для запуска функционала Электронного документооборота пользователем с ограниченными правами, не имеющим доступ к разделу Компания, из которого в свою очередь запускается меню с Электронными Документами ( Архив ЭДО ,Текущие дела ЭДО , Производные документы), а также меню Администрирование / Обмен с контрагентами / Настройки электронной подписи и шифрования.

1 стартмани

26.06.2020    2527    2    its_33    0    

Альфа-Ника: Кладовщик – расширение для 1С:Бухгалтерии 3.0

Учет ТМЦ Роли и права v8::БУ v8::Права БП3.0 Россия БУ Абонемент ($m)

Целью данного расширения является создание профиля “Кладовщик”, который очень востребован в типовой конфигурации 1С: Бухгалтерия Предприятия 3.0.

10 стартмани

16.06.2020    1678    0    alfanika    0    

Кто может создавать дубли?

Роли и права v8::Права ERP2 Абонемент ($m)

Ролей в ЕРП очень много, вручную не проконтролировать. Как определить у каких пользователей есть права на объект? Как определить роль, отвечающую за тот или иной объект метаданных? Какой профиль нужно назначить группе доступа? Куда отнести пользователя?

1 стартмани

13.06.2020    1526    1    Redokov    0    

Система доступа к объектам на уровне открытия форм

Роли и права v8::УФ v8::Права 1cv8.cf Украина Абонемент ($m)

Простенькая система настройки доступа в режиме Предприятия к различным объектам конфигурации на уровне открытия форм.

2 стартмани

10.06.2020    1610    5    xcooptex    0    

Анализ прав доступа по ролям объектов конфигурации на СКД

Роли и права v8::Права БП3.0 Россия Абонемент ($m)

Отчет сделан в виде стандартного отчета на системе компоновки данных типовой конфигурации, что делает возможность гибкой настройки и создания своего варианта отчета.

1 стартмани

09.06.2020    1721    9    ryan    2    

Дата запрета изменения по организации

Роли и права v8::Права ERP2 УТ11 КА2 Россия Абонемент ($m)

Расширение поможет быстро настраивать дату запрета изменения по организациям

1 стартмани

07.06.2020    1680    2    dima21m    0    

Копирование настроек пользователей

Роли и права v8 БП2.0 УТ10 УПП1 Беларусь Украина Россия Абонемент ($m)

Внешняя обработка для копирования настроек пользователей. Предназначена для типовых конфигураций, "Управление торговлей", редакция 10.3, БУХ 2.0, УПП, и их аналогов на рынке СНГ.

1 стартмани

28.05.2020    1590    10    JayZ    0    

Групповое удаление доступа из ролей, выгруженных в файлы

Роли и права v8 1cv8.cf Абонемент ($m)

Обработка предназначена для группового поиска и удаления доступа из ролей.

1 стартмани

27.05.2020    1340    1    unknown181538    0    

Настройка ограничений входа пользователей в базу (расширение)

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Настраиваем для пользователей 1С разрешенное количество открытых сеансов к текущей базе данных 1С в привязке к компьютерам. (У пользователя не будет возможности превысить допустимое количество сеансов или зайти с чужого компьютера).

2 стартмани

19.05.2020    6839    10    sapervodichka    12    

Установка пароля на изменение настройки пользователей "Дата запрета изменений" в БГУ 2

Роли и права Пароли v8::Права БГУ Государственные, бюджетные структуры Россия БУ Абонемент ($m)

В БГУ 2 (2.0.68.16) на уровне БСП у всех пользователей, имеющих роль "Администратор", есть возможность менять дату запрета изменений. Некоторым клиентам хотелось, чтобы только один пользователь мог менять дату запрета. Данное расширение позволяет определенному программно в расширении пользователю устанавливать пароль, а остальным пользователям позволяет менять даты только при вводе пароля. На красоту не претендует - не пеняйте.

1 стартмани

14.05.2020    2090    3    taras20    0    

Анализ прав пользователей

Роли и права v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Отчет по правам в разрезе пользователей, ролей и объектов метаданных.

1 стартмани

05.05.2020    3398    10    Batoo    0    

Запрет редактирования цены в документах продажи

Ценообразование, анализ цен Роли и права v8 v8::БУ v8::Права БП3.0 Россия БУ Абонемент ($m)

После установки расширения, только пользователи с полными правами или с доп. ролью смогут менять цену и сумму в документах реализации.

1 стартмани

26.04.2020    2375    0    Shalnov    2    

Создание нового пользователя путем копирования существующего, всех его ролей, групп и профилей

Роли и права v8::УФ v8::Права БП3.0 Россия Абонемент ($m)

Часто бывает так, что надо создать нового пользователя с определенными правами доступа. Перечисляются организации и роли нового пользователя. На это тратится иногда очень много времени. Часто бывает проще создать нового пользователя на основе уже существующего, а потом, если нужно подправить его права.

1 стартмани

23.04.2020    1856    3    user633783_Wladigor    0    

Поиск ролей и прав доступа в 1С 8.3

Роли и права v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Обработка позволяет упростить настройку ролей и прав доступа. Показывает набор прав и ролей к необходимым объектам, в том числе нетиповым.

1 стартмани

19.04.2020    2435    11    plotnikov1c    0    

Установка даты запрета изменения по расписанию

БСП (Библиотека стандартных подсистем) Роли и права v8 БП3.0 Абонемент ($m)

Внешняя обработка для установки даты запрета изменений по расписанию. Применяется для всех пользователей, кроме уже имеющихся в списке дат запрета.

1 стартмани

14.04.2020    2552    2    user1393353    0    

Установка кода доступа в 1С (обычные и управляемые формы)

Роли и права v8 v8::УФ 1cv8.cf Абонемент ($m)

Универсальная обработка по вводу кода доступа.

1 стартмани

03.04.2020    2735    4    Denr83    0    

Создание нового пользователя копированием

Роли и права v8 v8::Права УТ10 Абонемент ($m)

Создание пользователя ИБ и элемента справочника "Пользователя" копированием существующего.

1 стартмани

27.03.2020    2655    2    tamerlan922    0    

Установка групп доступа физических лиц

Роли и права v8 v8::СПР v8::Права ЗУП3.x Россия БУ Абонемент ($m)

Внешняя обработка для 1С: ЗУП 3 для установки групп доступа физическим лицам.

1 стартмани

13.03.2020    2368    4    SamMix    0    

Проверка прав по объекту метаданных у пользователя или роли и обратное

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Обработка позволяет посмотреть, какие пользователи или роли имеют доступ к объекту метаданных. Также к каким объектам имеет доступ роль или пользователь информационной базы.

1 стартмани

03.03.2020    3155    15    iCortezik    4    

Ограничение доступа по контрагентам для Бухгалтерии (RLS) 3.0 (3.0.75.58) - менеджер видит только своих контрагентов

Управление взаимоотношениями с клиентами (СRM) Адаптация типовых решений Роли и права v8 БП3.0 Россия БУ Абонемент ($m)

Расширение предназначено для Бухгалтерии 8 ред. 3.0. Типовая конфигурация остается на поддержке (с замком). Решает оно следующую задачу: Менеджеры по продажам должны видеть документы и отчеты только по контрагентам, которых они ведут.

5 стартмани

27.02.2020    3360    13    teyana    4    

Решение разработчика в зависимости от опыта работы. Как ограничить отображаемый пользователю список и ничего не потерять

Роли и права v8 1cv8.cf Абонемент ($m)

Решение разработчика в зависимости от опыта работы. Ограничение отображаемого пользователю списка без применения RLS.

1 стартмани

25.02.2020    2875    0    user633166    8    

Анализ прав доступа к метаданным конфигурации

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Лёгкий отчёт, предназначенный для анализа прав доступа к метаданным конфигурации. Написан без использования БСП (Библиотека стандартных подсистем).

5 стартмани

31.01.2020    3250    10    v_elkin    15    

Копирование настроек и дополнительных прав пользователей

Роли и права v8 УПП1 Россия Абонемент ($m)

Модификация обработки из https://infostart.ru/public/204756/. Не копируется основной ответственный, а кроме настроек копируются и дополнительные права.

1 стартмани

28.01.2020    2555    3    FullMoon    2    

Автоматическое создание ролей (объектов метаданных)

Роли и права v8 1cv8.cf Абонемент ($m)

Обработка позволяет создать 2 роли на объекты метаданных (Чтение и Изменение).

2 стартмани

22.01.2020    3153    3    kokorishvili    9    

Перенос пользователей ИБ через COM-соединение (обычные и управляемые формы)

Роли и права v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Необходимо скопировать несколько или всех пользователей в новую ИБ? Обработка (обычное и управляемое приложение) сможет это сделать!

1 стартмани

29.11.2019    3726    20    Denr83    0    

Менеджер подключений к удаленным рабочим столам (RDP)

Роли и права v8 Абонемент ($m)

Менеджер подключений к удаленным рабочим столам для организации доступа сотрудникам, без передачи паролей для доступа.

2 стартмани

19.11.2019    4316    6    Shalnov    1    

Изменение запрета редактирования в дереве по группам пользователей

Роли и права v8::Права УПП1 Россия Абонемент ($m)

Обработка позволяет менять дату запрета редактирования по пользователям в раскрывающемся списке группы пользователей. Тестировалась на УПП 1.3.126.2.

1 стартмани

19.11.2019    3211    1    trest30    0    

Очередной "мягкий" отключатель активных и не очень пользователей

Роли и права v8 1cv8.cf Россия Абонемент ($m)

Тема отключения пользователей не нова, но это чуть другой взгляд на проблему.

1 стартмани

15.11.2019    3619    4    ybatiaev    11    

Ошибка в ограничении доступа пользователей к списку Регистр накопления

Роли и права v8 БП3.0 Россия БУ Абонемент ($m)

Ошибка обновления Бухгалтерия предприятия, редакция 3.0 (3.0.74.51).

1 стартмани

11.11.2019    4990    1    Montecrizto    9